[Resolved] Not able to add New Elements

Home Forums Support [Resolved] Not able to add New Elements

Home Forums Support Not able to add New Elements

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #811894

    I have just activated Elements option and subsequently tried adding a new element(for creating to new page headers in place of legacy headers).However, clicking on the ‘Add new’ button gives me blank page. How can I resolve this issue?
    ( I tried the same on my localhost site and online site; both showed same results)



    I de-activated and deleted GP-premium plugin and re-installed it again .This time, I noticed that,all my previosu page headers are gone! Though ‘Page Headers’ menu appears on the admin page ,while clicking on “All Page Headers” I see a blank page ( wp-admin/edit.php?post_type=generate_page_header ) with a messge -saying :”Invalid post type” Also noticed that ‘Legacy page headers option is also not appearing when I select ‘Elements option’ under ‘Appearance’. I am afriad that I have messed up with all settings!!!

    Is there any way, I can revert to my old header option atleast?
    Pls help.

    GeneratePress 2.2.2
    GP Premium 1.7.7
    Lead Developer
    Lead Developer

    Hi there,

    A blank page could be caused by a couple of things. The most likely is your server doesn’t have enough PHP memory: https://docs.generatepress.com/article/increasing-php-memory-limit/

    If you didn’t deactivate the Page Header module in “Appearance > GeneratePress”, it should still exist with all of your existing Page Headers. If you deactivate the Elements module, the “Page Headers” menu item will reappear in your admin menu.

    If you did deactivate the Page Header module, you can force it to come back by added this line to your wp-config.php file:

    define( 'GENERATE_PAGE_HEADER', true );


    Thank you Tom for the quick reply.
    I just added the codes – “define(‘WP_MEMORY_LIMIT’, ‘128M’);” and define( ‘GENERATE_PAGE_HEADER’, true ); to my wp-config.php file.
    last part of it appears as follows:
    * @link https://codex.wordpress.org/Debugging_in_WordPress
    define(‘WP_DEBUG’, false);

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);

    define(‘WP_MEMORY_LIMIT’, ‘128M’);

    define(‘GENERATE_PAGE_HEADER’, true );

    Hope I have done it right!

    Unfortunatly, I couldn’t see any chnage in the status. The issue remains the same. I tried de-activating and re-activating the plugin also. Nothing changed.. What could be wrong? ..Is there anything else I should try? I hope I do not have to go for a fresh install of wordpress..!

    Pls revert..


    Another update!
    I just updated another website of mine (which is under contruction for over a year ) with wordpress 5.0.3 and latest version of GP and GP premium plugin . After activating ‘Elemets” ,I found the same issue with that site too..! same blank page appears without any dropdown option ! Looks like things are beyond my control… Could this be due to a server problem?

    Lead Developer
    Lead Developer

    It could be, it’s hard to tell without more information.

    Are there any recent errors in the error_log file on your server? If you can’t find the file, your hosting support should be able to help.

    We haven’t had any recent Element related updates, and haven’t received any other bug reports, so I assume something strange is happening locally for you.


    I just logged into my c-panel and checked the server for errors; but couldn’t find out any!!!

    I am very much disgusted now. I want to try all possibiltes before giving up…

    Any possibilty of a plugin clash?

    Will a fresh re-install of wordpress & GP Premium plugin help me to switch back to the Legacy headers that worked fine earlier? I am quite happy with that.!

    If nothing works out ,Probabbaly,I will consider changing the hosting service provideror or migrating to a high end hosting package as a last resort to make my GP sitework.

    It is really strange..I enocuntered same problem with my localhost install also ..


    Latest update!
    Looks like ..a plugin conflict is causing the isuue! I just de-activated all plugins. then activated GP premium alone..This time when I clicked on “Add New ” on Eelements page,the option to Choose Element Type appeared on the page..
    Finaly, a sigh of relief … !
    i will try to find out what plugin causes the issue and report it here for the information of other useres..
    Thanks a lot for your support..


    Final update!
    The plugin that casued trouble was “Link library”. Infact, a half page notification that kept coming from Link Library plugin author occupied the space where the “Element option drop down menu (add new) is supposed to be shown, on the elements page. Now everything is working fine as expected…
    Thank you Tom once again,for the right guidance…

    Lead Developer
    Lead Developer

    No problem! Glad you found the issue 🙂

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.