[Support request] Navigation become bigger for a second

Home Forums Support Navigation become bigger for a second

Viewing 15 posts - 1 through 15 (of 31 total)
  • Author
    Posts
  • #909344
    Sonja

    If I click from the homepage to a post, then the main navigation and logo become bigger for a second. What can be the problem?

    #909390
    David
    Staff
    Customer Support

    Hi there,

    would you mind flushing and disabling you cache plugin so i can take another look.

    #911009
    Sonja

    So i have changed my site logo and have made some design changes. But the problem is still there.

    When I let wp-rocket generate the critical css again, then the problem seems to go for a while. But after some time, it is there again und really anoying.

    I have stoped caching with the wp-rocket no chache plugin.

    #911338
    David
    Staff
    Customer Support

    It is possible to exclude some CSS from the Critical CSS. But are you noticing much speed difference without this option activate? Your site is running on HTTP 2 which means optimizing / combining CSS files is not really necessary and actually inadvisable.

    #911384
    Sonja

    Yeah, I have CSS and Javascript Minification disabled, because they recommend it because of http2, as you said.

    Butactually I don´t know, if this solves the problem. I will see it tomorrow.

    But I also have noticed, that with every refresh of the site, the H1 titles gets bigger for a second.

    This is a similar problem. What could that be?

    #911425
    Leo
    Staff
    Customer Support

    But I also have noticed, that with every refresh of the site, the H1 titles gets bigger for a second.

    This sounds like some sort of caching issue. It doesn’t happen on any of my fresh installs.

    It doesn’t happen in any of our sites here as well:
    https://generatepress.com/site-library/

    #911427
    Sonja

    I doesn´t have this problem in the past either. But after I made some changes in customizer, the problem wit the navigation begins. And then the problem with the h1 titles kicks in as well.

    Like I said, I have deactivate the Minification, but the problem with titles is still there.

    #911429
    Sonja

    I have noticed, that the problem with the titles are not just h1. Any titles, also in siedebar, have these problems.

    With each refresh, the titles gets bigger, like there were bold, and then go back to normal?

    What can be the problem? Why do you think, that caching do soemthing?

    #911440
    Leo
    Staff
    Customer Support

    Sounds like the CSS maybe getting loaded in the footer instead of the header by default.

    Can you disable all plugins except GP Premium and link us to the page in question?

    #911489
    Sonja

    I have already linked the page in the initial post. But I can not deactivate all the plugins for long. When is the best time to do this, so you can have a quick look?

    #911504
    Leo
    Staff
    Customer Support

    We can’t really promise when to have a look.

    Maybe it’s best to duplicate the situation on a test server?

    As for now, I would assume clear and disabling WP Rocket would solve the issue.

    #927124
    Sonja

    My problem is still there.

    But I have this problem only lately. Maybe after updating GP or wp-rockt, I don´t know.

    But before, i had not have this problem.

    I have wrote to the wp-rockt support and they answered as follow. in particular nr.3 seems to be interessting. How can I do that?

    Any other ideas?

    What you’re seeing is called a “Flash Of Unstyled Content” (FOUC): https://en.wikipedia.org/wiki/Flash_of_unstyled_content

    FOUC issues can be related to our Optimize CSS Delivery option: https://docs.wp-rocket.me/article/108-render-blocking-javascript-and-css-pagespeed#critical-path-css

    This option isn’t appropriate for every website, depending on how it’s coded. If disabling this option solves the problem, then your options at that point would be to:

    1) Keep the Optimize CSS Delivery turned off for the whole site

    2) Turn off the option just for affected pages: https://docs.wp-rocket.me/article/677-turning-off-additional-options-on-specific-page-post

    3) Use the Fallback field to specify your own critical path CSS: https://docs.wp-rocket.me/article/108-render-blocking-javascript-and-css-pagespeed#fallback-css

    When I inspect your page it looks like you may actually be using a Generate Press option for this as the ID for the critical CSS doesn’t match the ID we would use. The ID for your critical css is generate-style-inline-css whereas we use the ID rocket-critical-css. You could try disabling the option in Generate Press and checking to see if the critical CSS feature in WP Rocket works better for you.

    #927205
    Leo
    Staff
    Customer Support

    Do you have the CSS options checked in Customizer > General?

    If so maybe try unchecking it? That’s the only CSS option from GP.

    #927249
    Sonja

    Do you mean this option?
    “Cache dynamisches CSS
    Cache CSS, das auf Deinen Optionen basiert, um Deine Performance zu verbessern”

    It is unchecked. But I don´t know what this mean. What to do?

    And it is strange, that I don´t have this problems for years. And suddenly it is there. Can only have something to do with an update.

    #927258
    Leo
    Staff
    Customer Support

    It was unchecked already?

    Nothing in GP’s updates should trigger this.

    Might to good to uncheck the Optimize CSS Delivery as WP Rockets suggested or ask them for a bit more info?

Viewing 15 posts - 1 through 15 (of 31 total)
  • You must be logged in to reply to this topic.