[Resolved] Mobile optimization of shop page and individual product pages

Home Forums Support Mobile optimization of shop page and individual product pages

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #937355
    Westin

    Hey guys,

    I have a problem regarding mobile optimization of my website.

    The theme customizer shows that my mobile site is working, google mobile testing shows that it is compatible, but I seem to have a problem directly on the product pages of my website on mobile phones. It appears that the products themselves are showing up like they would on desktop instead of switching to the mobile view that is shown on the customizer page.

    When I open up my product page on my desktop and size down the browser everything is working fine, but when I open up the product page on my phone (and I’ve tested this on several other phones), the page looks like it would on desktop and is definitely not optimized for mobile. I also see this problem on my “shop” page.

    I’ve included a link to the shop page which you can use to re-create the problem. Be sure to try it on your mobile phone to see what I am talking about.

    You can also see the problem if you click on any of the individual products.

    #937361
    Leo
    Staff
    Customer Support

    Hi there,

    Any chance you can do this first?
    https://www.screencast.com/t/sAZU8h7bUcE

    Let me know 🙂

    #937378
    Westin

    Hi Leo,

    Well, it seems that deactivating WP rocket fixed the issue so thanks for that recommendation.

    Is there a way that I can use WP rocket and still get the benefits of lazy loading and caching without affecting the layout of the product pages and what not?

    #937379
    Leo
    Staff
    Customer Support

    There is an option in WP Rocket that needs to be unchecked so it doesn’t strips the CSS inside media query which was causing the issue.

    I can’t remember the exact name of that setting but there shouldn’t be too many to go through and test it out.

    Might be good to check with their support if you can’t figure it out.

    Let me know if it still doesn’t work after all that 🙂

    #937384
    Westin

    Hi Leo,

    I think I found it. It’s the “Optimize CSS delivery”. When I uncheck that box it seems that everything else works. Just putting it here in case anyone else has this issue.

    Thanks for the help!

    #937396
    Leo
    Staff
    Customer Support

    Thanks for reporting back!

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.