[Resolved] Mobile Menu Background Hover Not Matching Desktop

Home Forums Support Mobile Menu Background Hover Not Matching Desktop

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #871933
    Kiley

    I’ve changed the primary navigation colours on my site and they work fine on desktop. When I switch the site to mobile, however, the background hover colour works for the individual menu items but not for the menu header itself.

    You can see in the image the background in the Menu header is grey when it should be pink link the other links in the menu are when they’re hovered.

    [IMAGE REMOVED]

    GeneratePress 2.2.2
    GP Premium 1.7.8
    #872018
    Leo
    Staff
    Customer Support

    Hi there,

    I think this might be a caching issue.

    Can you turn off Siteground optimizer for now?

    Let me know 🙂

    #872088
    Kiley

    I’ve turned off all the catching in SG Optimizer (which is just the Dynamic Caching option as my plan doesn’t cover Memcache) and refreshed the site. I even tried purging the cache manually before doing so. The issue is persisting.

    #872124
    Leo
    Staff
    Customer Support

    I still see the Site Ground Optimizer on.

    Can you leave it off so I can see it?

    I believe the combined CSS should be the problem.

    #872128
    Kiley

    I’ve deactivated the plugin entirely and now there’s no highlight when the Menu is selected. That’s better than the dark highlight but how can I keep this while still running the SG Optimizer plugin?

    #872280
    David
    Staff
    Customer Support

    Hi there,

    we see quite a few issues with SG Optimizer messing with the order of the CSS. Personally i would not use it. You could follow our optimization tips instead:

    https://generatepress.com/fastest-wordpress-theme/

    #872483
    Kiley

    Is there an image optimizer you would personally recommend then? The site will be for a webcomic, so an image optimizer that automatically optimizes images as they’re uploaded is valuable. And, ideally, free given that SG Optimizer is free and performs that function but it seems I have to disable it with GeneratePress.

    Looks like Autoptimize has one but there’s a subscription fee.

    #872511
    David
    Staff
    Customer Support

    You can try deselecting the Minify CSS option in the SG Optimizer settings, this should stop that particular problem.

    #872694
    Kiley

    Thanks! That didn’t work but deselecting ‘Combine CSS Files’ did

    #872698
    David
    Staff
    Customer Support

    Perfect – i couldn’t see that in there settings so thanks for sharing that.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.