[Resolved] Menu has broken since update

Home Forums Support Menu has broken since update

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #1489308
    troyw

    Hey team,
    I have just updated GP and found that the navigation menu has placed the last menu item under the Logo and gaps have increased between menu items.
    My first action was to turn turn off Litespeed Cache as it often causes such issues, but it makes no difference if Litespeed is on or off.
    I then tried to edit the menu in Customizer but nothing changes when I edit the settings.
    I have gone through all the plugins turning off, clearing cache and checking again, but still menu is broken.

    Any ideas what could be happening?

    Thanks

    #1489347
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    It looks like the menu items are just too wide to fit in the allowed area.

    What happens if you decrease your menu item width in Customize > Layout > Primary Navigation?

    #1489359
    troyw

    Hey Tom,
    I tried that, but nothing happens when I adjust the width in Customizer?

    #1489362
    troyw

    Sorry Tom,
    It is working now, but not showing the edit in real time using customizer. I have to save it first and then refresh live page. Strange.

    #1489364
    Tom
    Lead Developer
    Lead Developer

    Strange – just tested the Customizer preview and all is working on my end. Are you using GP Premium 1.12.2?

    #1489366
    troyw

    Just updated to the latest about an hour ago, which is when issue started as far as I a aware. Any idea why the customizer is not working in real time?

    #1489369
    troyw

    OK, so it is that hideous Litespeed Cache stopping the customizer working in realtime. I have disabled Litespeed now and customizer now works as it should.
    I was forced to use Litespeed as I was having some YSLOW issue that I could not explain previously and Litespeed fix them. I have just tested without Litespeed and the site is now performing as it should.

    Bad Litespeed Cache.

    Not sure why Layout settings changed though, that’s a bit odd, but I can fix now. Thanks

    #1489381
    Tom
    Lead Developer
    Lead Developer

    No problem!

    Which layout settings changed?

    #1489382
    troyw

    I have just checked the website again using Web Dev tool and without LiteSpeed, my performance rating is really bad at just 46. If I turn on Litespeed it improves drastically. Without Litespeed I am getting all the below issues;

    High
    Performance
    Eliminate render-blocking resources
    Eliminate render-blocking resources
    High
    Performance
    Efficiently encode images
    Efficiently encode images
    High
    Performance
    Serve images in next-gen formats
    Serve images in next-gen formats
    High
    Performance
    Reduce initial server response time
    Reduce initial server response time
    High
    Performance
    Avoid multiple page redirects
    Avoid multiple page redirects
    High
    Performance
    Preload key requests
    Preload key requests
    Medium
    Best Practices
    Does not use HTTPS
    Does not use HTTPS
    Medium
    Best Practices
    Includes front-end JavaScript libraries with known security vulnerabilities
    Includes front-end JavaScript libraries with known security vulnerabilities

    Should I start a new ticket?

    #1489384
    Tom
    Lead Developer
    Lead Developer

    Autoptimize can help with the render-blocking issues: https://docs.generatepress.com/article/configuring-autoptimize/

    Two of those seem to be related to your images, so make sure they’re fully optimized the best you can.

    If it’s still bad feel free to open a topic and we’ll try to make some more suggestions 🙂

    #1489385
    troyw

    I had to change the >Layout>Menu Width and the Layout>Header>Header Padding

    #1489399
    Tom
    Lead Developer
    Lead Developer

    Strange, haven’t had any other reports of this issue. It’s possible that caching was getting in the way of seeing the actual results – 3.0 was a major update, so caching has been a bit of a pain for a lot of people.

    #1489432
    troyw

    Hey Tom,
    This article doesn’t tell me where to find these Autoptimize settings? Where are they?

    #1489563
    Leo
    Staff
    Customer Support
    #1489565
    troyw

    Hey Leo,
    Autoptimize is not in my Settings Menu?

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.