[Resolved] Masonry problem in GP 1.5

Home Forums Support Masonry problem in GP 1.5

This topic contains 16 replies, has 3 voices, and was last updated by  Branislav Pakic 11 months ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #419684

    Branislav Pakic

    I’m having a problem with masonry in GP 1.5. When I click the load more button posts are not loaded, I just get empty space instead. I thought it was because of the caching plugin, but I cleared the cache and the problem remained. For now I had to revert to GP 1.4.3.

    The website in question is https://greencamp.com/ though it’s with GP 1.4.3 now. I have a local copy of the website where I installed GP 1.5. Here is a sceen capture that demonstrates the problem (all plugins but GP premium are deactivated):
    https://1drv.ms/v/s!AjeElcrX4ad7p6AP6i-mOp6gvzm1pw

    #419686

    Robert

    I feel like I’m losing my mind but I can’t get “excerpt” instead of full post to work in blog settings. I’ve tried to set and reset 100 times, it’s just not setting right. It keeps displaying the full post no matter what. Can someone (anyone) confirm if they can set their blog page to show excerpts?

    #419690

    Tom Lead Developer

    Branislav – any chance you can update to GPP 1.5, then take a Duplicator of the site?: https://en-ca.wordpress.org/plugins/duplicator/

    Then shoot me the .zip file and I’ll install it on my localhost. I won’t be able to help without seeing the issue first hand.

    Robert – any chance you can start your own topic?

    Thanks!

    #419708

    Robert

    Actually, I figured it out. For some reason the very first post was not showing as an excerpt. Deleted it and subsequent new posts are showing accurately. Odd but oh well.

    #419710

    Branislav Pakic

    Sure, will do. Should I use the Pre-Sale Question contact form to send it to you?

    #419714

    Tom Lead Developer

    That would be great – thanks!

    #419723

    Branislav Pakic

    Sent πŸ™‚

    #419816

    Tom Lead Developer

    Found the issue.

    The new infinite scroll looks for the immediate container of the article elements.

    In your case, you have a front-page.php template which adds more than one loop to the page, including separate article elements not a part of the infinite scroll container.

    I’ll be releasing an update today with a couple fixes, and I’ve made it so the check for the container is a little more specific, which should fix your issue πŸ™‚

    Thanks!

    #419895

    Branislav Pakic

    Awesome! Thank you!

    #420054

    Tom Lead Developer

    I just released GPP 1.5.1 which should fix this πŸ™‚

    #420500

    Branislav Pakic

    I’m happy to report that the problem is solved, masonry loads up correctly now πŸ™‚

    BTW I think that some blog settings are not remembered from the previous version. I noticed that when I updated GPP the comment counts in the loop were suddenly visible on the homepage and I had to go to the customizer to turn them off. Not a big deal, but I wanted to let you know.

    #420899

    Tom Lead Developer

    That’s odd – a migration function should have fired on your first Dashboard load after updating. The migration should have kept all of your original settings.

    Sorry about that!

    #421041

    Branislav Pakic

    No problem at all. If I remember on Monday, I’ll test to see if it’s repeatable. Hopefully it was a one time thing due to going up and down in versions and saving settings in between.

    #421191

    Tom Lead Developer
    #423904

    Branislav Pakic

    I just tried to replicate the problem.

    I downgraded my local copy of the site from GPP 1.5.2 to GPP 1.4.3 – on blog page I lost featured images, author, date and category which were all set to show.

    I manually set everything back as it was – show featured image, show author, show date, show category, hide tags, hide comments.

    Then I upgraded to GPP 1.5.2 and everything was OK, except that the comments were visible again so I had to go to the customizer and hide them manually.

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.