Masonry Post Width grid bug

Home Forums Support Masonry Post Width grid bug

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #182540
    Tara

    Hi Tom

    When a post with a larger Masonry Post Width is the first on a blog/archive page, it breaks the masonry grid and all the posts are in a single column.

    Example: http://www.tidybag.uk/news/
    Masonry Post Width: Medium for ‘The Return Of The Wombles’ (Global setting for other posts)
    Masonry Block Width: Small
    Masonry Most Recent Width: Small

    In the source code, I see <div class="grid-sizer width4"> where it’s normally width2, while the first article is width2 but should be width4.

    Thanks

    Tara

    #182653
    Tom
    Lead Developer
    Lead Developer

    Hi Tara,

    Can you try updating to the latest version?

    Once you’ve done that, be sure to clear any caching plugins you may have installed.

    #182686
    Tara

    Hi Tom

    Thanks – I’ve already updated everything to the latest version, and tried various settings before reporting this. It still happens on the parent theme and with all plugins disabled except Generate Blog. So I hope you can reproduce it.

    Thanks

    Tara

    #182771
    Tom
    Lead Developer
    Lead Developer

    Replicated and fixed.

    Want to test it out? Shoot me an email to support@generatepress 🙂

    #183142
    Tara

    Hi Tom

    That fixes it for my specific settings, with a Small grid. But when I test setting the Masonry Block Width to Medium instead, it pushes everything into a single column again (regardless of the Most Recent Width or Masonry Post Width).

    Tara

    #183329
    Tom
    Lead Developer
    Lead Developer

    I’ll play with the logic some more and will update this topic.

    #226046
    Ken

    Hi, any more progress on this?

    I also have this problem – I create an aside post that I want to carry an Advertisement in amongst the small blog masonry tiles, setting it to Medium Size – opting out of the Masonry Global settings – and it breaks the site.

    I managed to create one Medium tile that kind of works but only if I leave it where it is – If I change the date of publish of this tile to bring up to date so it’s seen near the top of the blog (advertising) it breaks the site. I’m forced to leave global masonry settings to small tiles.

    Help appreciated.

    http://www.pembrokeshirelifeonline.uk

    Thanks

    Ken

    #226120
    Tom
    Lead Developer
    Lead Developer

    Hi Ken,

    Hard for me to tell what’s going on with your site as you have caching enabled and a javascript error which looks like it’s being caused by your disable right click plugin.

    Any chance you can disable those two plugins and enable the medium post so I can see?

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.