Black Friday Sale! Get up to $30 off GP Premium! Learn more ➝

[Resolved] Major problem with my GP premium license implementation

Home Forums Support [Resolved] Major problem with my GP premium license implementation

Home Forums Support Major problem with my GP premium license implementation

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #188345
    FridRick

    Hi,
    After much essays and errors with WordPress themes, I became totally convinced of GeneratePress usefulness, and did thus purchase a premium license in January 2016. Got a license key, downloaded the gp-premium.zip file, but didn’t create an account.

    Now, after a recent hostile hacking of my hosted WordPress, and as the site still was in its infancy, I just wiped all of it.

    Problem is that after I installed anew a WordPress (4.5), the gp-premium.zip file I downloaded last January doesn’t work anymore: WordPress returns an error message stating that “the theme has no style.ccs file” (accurate French to English translation here).

    As concurrently the GP “Updates” option* in the WordPress admin panel, that was the advertised other way to validate the GP license key, has manifestly disappeared, I’m at a complete loss as how to implement my GP premium license on this new WordPress install.

    Thanks in advance for the solution,

    FridRick

    *Note:
    “1. Go to “Appearance > GeneratePress”.
    2. Enter your license key into the “Updates” box.
    3. Click the “Update” button next to the field where you added your license key.”

    #188361
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    WordPress returns an error message stating that “the theme has no style.ccs file

    This should help with that: https://generatepress.com/knowledgebase/missing-style-css-stylesheet/

    Let me know 🙂

    #188394
    FridRick

    Hi Tom,

    Thanks for your quick answer!

    Trying to install GP premium as a theme rather than a plugin was a n00b mistake from my part (forgot this part!)

    After a couple of install-delete ops (right sequence being: install GP as theme first, and *then* install premium as a plugin) all seems OK.

    Many thanks,

    FridRick

    #188396
    Tom
    Lead Developer
    Lead Developer

    Glad it’s all working now 🙂

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.