[Resolved] Long title overlays in just one line – a "micro-bug?

Home Forums Support Long title overlays in just one line – a "micro-bug?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1221504
    Walter

    Researching why I had a long <h3> title text as an overlay in one line I found the following details:
    1) The Firefox Inspector showed at Inline:2 following code:
    h3 {
    font-size: 10px;
    line-height: 0em;
    }

    2) In the folllowing code block I found it: “h1{font-weight:600;font-size:15px;}h3{/*! font-size:10px; */line-height:0em;}.site-info{font-size:13px;}”

    body{background-color:#ffffff;color:#000000;}a, a:visited{color:#000000;}a:visited{color:#000000;}a:hover, a:focus, a:active{color:#b2b2b2;}body .grid-container{max-width:1100px;}.wp-block-group__inner-container{max-width:1100px;margin-left:auto;margin-right:auto;}.site-header .header-image{width:30px;}body, button, input, select, textarea{font-family:”Ubuntu”, sans-serif;font-size:19px;}body{line-height:1.6;}p{margin-bottom:0.3em;}.entry-content > [class*=”wp-block-“]:not(:last-child){margin-bottom:0.3em;}.top-bar{font-weight:200;font-size:16px;}.main-title{font-weight:400;text-transform:lowercase;}.site-description{font-weight:400;font-size:13px;}.main-navigation a, .menu-toggle{font-weight:400;}.main-navigation .main-nav ul ul li a{font-size:14px;}h1{font-weight:600;font-size:15px;}h3{/*! font-size:10px; */line-height:0em;}.site-info{font-size:13px;}@media ……….

    3) defining “line-height: 1.3em;” solved the “micro-bug”.

    4) Having in most of the cases short titles and the line-height set by usage in my child files I did not get the result as described before.

    This is just to let you know.
    And maybe you actualize this in the internal css file.

    Thank you – and I still love working with GP!
    Walter

    #1221530
    Leo
    Staff
    Customer Support

    Hi there,

    What is your line-height setting in Customizer > Typography > Headings > H3?

    Let me know 🙂

    #1225174
    Walter

    Hi Leo,
    I think that was the reason. Just H3 had a value of “0”. All the other Hx had “” or a value like “1.2”em. I do not remember that I have ever changed H3, but you know … Is “” in general ok or should I set for every Hx a certain value?
    As ever – you are great!
    Walter

    #1225177
    Leo
    Staff
    Customer Support

    It generally should be at least one. Otherwise you would get the overlap issue.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.