Black Friday Sale! Get up to $30 off GP Premium! Learn more ➝

Localhost – XAMPP and addon issue

Home Forums Support Localhost – XAMPP and addon issue

Home Forums Support Localhost – XAMPP and addon issue

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #205058
    Ragunaath

    I purchased the Premium theme / addons today, Before uploading the theme files/ addons on to hosting.I needed work site on XAMPP – localhost, addons doesn’t downloaded as zip file, though I copied the addons to plugin directory inside wp-content,it doesn’t shows up.

    Kindly resolve this

    #205070
    Max

    I can confirm that add-on won’t update on Xammp installation. You have to do it manually.

    1. log in to gp go to your account. Make a copy of your key number and save it in notepad.
    2. Also in your account you will find the link to download a copy of the add ons. Click on the link and download the zip file and then save somewhere on your desktop.
    3. Start your website in Xampp. Log in to admin. Go to plugins and select upload new, browse to the location you saved the add ons zip on your desktop. And upload. Then click on activate.
    4. Then go to apearance, generatepress, and check that your addons are activated. If not activate them.
    5. Then copy the key you saved in notepad and paste it in the update key field to the right of the addons screen. Click on the update button and you should get the green updated tick.

    Every time Tom releases a new update to the addons you will have to deactive and then delete the addons plugin. Then go back to the gp website and download the latest version using the link in your account. And then repeat the above process.

    Hope that helps.

    Kind Regards

    Max

    #205110
    Tom
    Lead Developer
    Lead Developer

    Hmm, I personally use XAMPP with no issues. Make sure the cURL is enabled on the server: http://stackoverflow.com/questions/3020049/how-to-enable-curl-in-xampp

    To save the add-ons as a zip file, right click the download link and “save as”. This will save it as a zip.

    Otherwise, upload the gp-premium folder to the wp-content/plugins folder on your server.

    More info here: https://generatepress.com/knowledgebase/install-activate-addons/

    #211645
    Max

    Hey Tom.

    Check my php.ini file and it already has the semicolon removed on the the curl line.

    But I still cannot update your premium addon in xampp. I get the following error:

    The update process is starting. This process may take a while on some hosts, so please be patient.

    Enabling Maintenance mode…

    Updating Plugin GP Premium (1/1)
    Downloading update from …
    Unpacking the update…
    An error occurred while updating GP Premium: Could not copy file. gp-premium/disable-elements/languages/generate-disable_elements-fr_FR.mo
    Disabling Maintenance mode…

    All updates have been completed.

    ————————-

    How can I fix this

    Kind Regards

    Max

    #211648
    David

    If you are using the Safari browser on a mac, it unzips zip files automatically.
    To change this, refer to this article…
    Might be useful.

    https://wiki.umbc.edu/pages/viewpage.action?pageId=31919091

    #211719
    Tom
    Lead Developer
    Lead Developer

    Could not copy file.

    This is a permissions issue.

    However, permissions shouldn’t be an issue in XAMPP, but that’s where that error comes from.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.