[Resolved] left sidebar menu now displays below content on mobile, on update to GP 1.3.46

Home Forums Support left sidebar menu now displays below content on mobile, on update to GP 1.3.46

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #301452


    I’ve got an odd problem that occurred on upgrading from GeneratePress 1.3.44 -> 1.3.46 and GP Premium 1.2.94 -> 1.2.96.

    I’ve got the primary navigation to display in the left sidebar, with some content inserted via hooks above and below it. Before upgrading (see http://www.brooklands-vintage-wedding-cars.co.uk), the menu displayed at the top of the page on mobile and tablet.

    However, after upgrading (see http://gp.ryedalewebdesign.com), the menu now displays after the content, near the bottom of the page.

    Is there a way to fix this and restore the menu location on mobile/tablet back to the top of the page?


    GeneratePress 1.3.46
    GP Premium 1.2.96
    Lead Developer
    Lead Developer

    Hmm, that’s very strange. Can’t reproduce that on my development site.

    Any caching plugins installed?

    Can you try #1 on this page?: https://docs.generatepress.com/article/debugging-tips/


    I haven’t got any caching plugins installed. I’ve deactivated all the plugins on the site, and activated them one by one until I get to GP Premium.

    So, if I deactivate GP Premium, the menu displays at the top – when I reactivate it, the menu drops down below the content again!

    So I went through the same process with each of the GP Premium add-ons, deactivating and reactivating them, until I got down to ‘Disable Elements’ – if this is deactivated the menu behaves as expected, but when this is reactivated, then the menu drops below the content.

    Now, this isn’t actually a problem as I don’t make use of this add-on on this particular site (I activate all the add-ons by default on all of my sites), but this seems like a curious issue.

    Thanks for your help.

    Lead Developer
    Lead Developer

    Hmm that is strange – Disable Elements is activated on my dev install.

    Did you have any of the elements disabled on the page using the Disable Elements settings?


    Interestingly, I had the ‘Header’ element disabled, but only on the front page – this was the page that showed the menu after the content. Al the other pages (which didn’t have the header element disabled) displayed the menu as expected.

    Once I unticked the ‘Header’ element, the menu displayed OK.

    I think I must have tried this out before deciding to hide the header using css.

    As far as I’m concerned, this issue is resolved – thanks for your help Tom – awesome support as always!

    Lead Developer
    Lead Developer

    Thanks for pointing this out! I’ll see if I can improve the behavior when the header is disabled 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.