Cyber Week Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Latest Update

Home Forums Support Latest Update

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #161548
    Pauline

    Hi, I have just updated my generatepress theme and now some code is showing at the top of my site.

    I have deactivated all plugins and it is not a plugin.

    I have changed themes and it is not happening on any other theme.

    Here is the code below, it is showing at the very top of my site. I have changed themes for the moment, but really want the generatepress theme back again.

    $SA = {s:247240, tag_info: “1.0.1-autotag”, asynch: 1, useBlacklistUrl: 1};(function() { var sa = document.createElement(“script”); sa.type = “text/javascript”; sa.async = true; sa.src = (“https:” == document.location.protocol ? “https://” + $SA.s + “.sa” : “http://” + $SA.s + “.a”) + “.siteapps.com/” + $SA.s + “.js”; var t = document.getElementsByTagName(“script”)[0]; t.parentNode.insertBefore(sa, t);})();

    thank you.

    #161549
    Tom
    Lead Developer
    Lead Developer

    Hi Pauline,

    It looks like a script either added by you or a plugin for “siteapps.com”.

    Do you recall adding any scripts like this? If so, where did you add it?

    If not, do you have any plugins that connect to siteapps.com?

    #161551
    Pauline

    Hi Tom, thanks for reply, I have no idea of a plugin that connects to siteapps.com I don’t even know what siteapps.com is?

    Before the update I had this added code below to ‘searchform’ and I copied it and added it again after the update to ‘searchform’
    Problem is, I can’t remember why I did it in the first place but thought I better do it again. I have deleated it and updated searchform, but now it is blank. Would this be the problem, because the code is still there?
    <script>
    (function() {
    var cx = ‘partner-pub-8690195739326374:3160004724’;
    var gcse = document.createElement(‘script’);
    gcse.type = ‘text/javascript’;
    gcse.async = true;
    gcse.src = (document.location.protocol == ‘https:’ ? ‘https:’ : ‘http:’) +
    ‘//cse.google.com/cse.js?cx=’ + cx;
    var s = document.getElementsByTagName(‘script’)[0];
    s.parentNode.insertBefore(gcse, s);
    })();
    </script>
    <gcse:search></gcse:search>

    Pauline.

    #161553
    Pauline

    Tom, I just want to add, it is not there when I change to another theme.

    #161554
    Pauline

    Ok I remember the script is for the google search form. 🙂

    #161555
    Tom
    Lead Developer
    Lead Developer

    That could be the problem – it’s hard for me to tell without seeing your files.

    This code isn’t in the core theme anywhere – maybe it’s this plugin?: https://wordpress.org/plugins/siteapps/

    If you think it’s somewhere in the theme, try re-installing it so all of the files are replaced with new ones.

    #161556
    Tom
    Lead Developer
    Lead Developer

    Ah, so you found and fixed it? 🙂

    #161557
    Pauline

    No I havn’t fixed it Tom, the problem is still there, it is not the google search form script.

    #161560
    Pauline

    ok thanks, I want to just let you know that I don’t have that plugin, and it can’t be the google search form script because that was working fine before theme update and how do I do another theme update?

    #161561
    Tom
    Lead Developer
    Lead Developer

    You can re-install by:

    1. Activating another theme
    2. Deleting GeneratePress
    3. Re-installing GeneratePress: https://generatepress.com/knowledgebase/installing-generatepress/

    That will make sure you have all of the default files.

    Let me know 🙂

    #164771
    rAF

    Hi dear,
    it s not matter of plugin. I saw in an shared hosting that a kind of service offered by the provider, and which name is SITEAPPS, for strange reasons, insert that code in YOUR code.

    This happen, when you have activated the SITEAPP service for your domain. So if you want solve, just deactivate that service on your domain.

    Here the code… from siteapps
    http://support.siteapps.com/entries/490014-Implementing-SiteApps-tag-on-your-site-for-the-1st-time-

    Hope can help

    #164853
    Tom
    Lead Developer
    Lead Developer

    Thanks for sharing! That makes perfect sense 🙂

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.