[Support request] “Last Updated Date” Not Displaying

Home Forums Support “Last Updated Date” Not Displaying

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1499021
    Andrew

    I think there’s a bug in the latest GP release. I have this code in Simple CSS:

    .posted-on .updated {
    display: inline-block;
    }

    .posted-on .updated + .entry-date {
    display: none;
    }

    .posted-on .updated:before {
    content: “Last Updated “;
    }

    It has been working fine until the latest update. Now however, the date shows in the Customizer but not when the site’s live.

    Any ideas?

    #1499046
    Elvin
    Staff
    Customer Support

    Hi,

    Can you try disabling all caching plugins and check if it still occurs?

    Let us know how it goes. Thanks.

    A wise man once said:
    "Have you cleared your cache?"

    #1500491
    Andrew

    Hi Elvin,

    After disabling the Autoptimize plugin, the date shows again.

    Any ideas on how to solve this issue, with the Autoptimize plugin active?

    #1500522
    Elvin
    Staff
    Customer Support

    Strange,

    I don’t see the dates on your site on my end.

    Here’s what I’m seeing on my end. https://share.getcloudapp.com/E0urylwn

    Can you tried clearing your browser cache too? You can try viewing your site in Incognito mode.

    A wise man once said:
    "Have you cleared your cache?"

    #1500567
    Andrew

    Hi Elvin,

    Sorry, I should have explained it better. I disabled Autoptimize, checked the site and it showed the date. Then I enabled Autoptimize again. So when you looked at it, Autoptimize was enabled.

    Can I force the date to be always shown, ie override Autoptimize for the date display function?

    #1500573
    Elvin
    Staff
    Customer Support

    Sorry, I should have explained it better. I disabled Autoptimize, checked the site and it showed the date. Then I enabled Autoptimize again. So when you looked at it, Autoptimize was enabled.

    Ah that makes sense.

    If that’s the case then you really must clear Autoptimize’s current cache so that Autoptimize can rebuild the cache again w/ your newer CSS settings.

    Can I force the date to be always shown, ie override Autoptimize for the date display function?

    Sure. Perhaps you’ve followed this already: https://docs.generatepress.com/article/show-the-updated-post-date/

    If so, you’ll just have to clear cache after applying this.

    Note: It’s helpful to clear cache every time you make changes to your site.

    A wise man once said:
    "Have you cleared your cache?"

    #1500627
    Andrew

    I cleared the Autoptimize cache, no change. Viewed website in Incognito mode, no change. Any other ideas?

    Thanks for the link, but I already have this CSS on the site as per the screenshot of the Customizer in my first post (sent privately). I’m a bit confused, am I missing something?

    #1500637
    Elvin
    Staff
    Customer Support

    We can try adding !important to the property.

    Example:

    .posted-on .updated {
    display: inline-block !important;
    }

    A wise man once said:
    "Have you cleared your cache?"

    #1500697
    Andrew

    Problem solved, thanks Elvin!

    #1500705
    Elvin
    Staff
    Customer Support

    Nice one.

    No problem. 🙂

    A wise man once said:
    "Have you cleared your cache?"

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.