[Resolved] JSON error with Podcast Embed Code

Home Forums Support JSON error with Podcast Embed Code

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #1520303
    Aaron

    I am getting the following JSON error: “Updating failed. The response is not a valid JSON response” now because of my podcast embed code. This embed code has always worked on my site. Why all of a sudden is it not working now? I didn’t change anything.

    Here is the webpage:
    https://golocalchurch.com/podcast/?preview=true

    Here is the embed code I am using in a Shortcode block right above the podcast badges:
    <iframe src=”https://www.podbean.com/media/player/multi?playlist=http%3A%2F%2Fplaylist.podbean.com%2F5814993%2Fplaylist_multi.xml&vjs=1&size=430&skin=2&episode_list_bg=%23ffffff&bg_left=%231E73BE&bg_mid=%236C97BD&bg_right=%238DAECB&podcast_title_color=%23000000&episode_title_color=%23000000&auto=0&share=1&fonts=Helvetica&download=0&rtl=0&show_playlist_recent_number=10″ title=”The Doers Class Podcast” width=”100%” height=”430″ scrolling=”no” style=”border: none;”></iframe>

    #1520702
    David
    Staff
    Customer Support

    Hi there,

    looks like you have some odd quotes in your code: eg. and . They all need to be "

    I swapped them here and ut worked on my test installL

    <iframe src="https://www.podbean.com/media/player/multi?playlist=http%3A%2F%2Fplaylist.podbean.com%2F5814993%2Fplaylist_multi.xml&vjs=1&size=430&skin=2&episode_list_bg=%23ffffff&bg_left=%231E73BE&bg_mid=%236C97BD&bg_right=%238DAECB&podcast_title_color=%23000000&episode_title_color=%23000000&auto=0&share=1&fonts=Helvetica&download=0&rtl=0&show_playlist_recent_number=10" title="The Doers Class Podcast" width="100%" height="430" scrolling="no" style="border: none;"></iframe>

    #1520756
    Aaron

    That’s odd that Podbean’s code would be generated like that. I cut/pasted your code into an html block on the “Doers Class Podcast”, but I still get the JSON error that won’t allow me to update the page. I deleted the block so I can at least update that page for now.

    Is it possible for you to go into the site and look at the issue?

    #1520798
    David
    Staff
    Customer Support

    How are you adding the embed code ? Is it inside a HTML Block ?

    #1520802
    Aaron

    Yes…inside an HTML block, and the block’s “preview” seems to show the podcast player just fine.

    #1520820
    David
    Staff
    Customer Support

    I got the URL and the user – can you share the password ?

    #1520844
    Aaron

    I put it in Private Info

    #1520991
    Leo
    Staff
    Customer Support

    Do you get the same issue when using a twenty series WP theme?

    #1522133
    Aaron

    I just changed the theme to WP Twenty Fifteen and still had the same issue. I guess this rules out GP as having any issue? Could you point me in the right direction where the problem may lay? I can only think of my server having an issue or else Podbean, which generates the embed code for the player. I would think that the embed code is good since it worked for David on a test install.

    I feel bad I caused you all so much effort when it turns out not to be a GP issue. Any direction you can point me in is greatly appreciated.

    #1522608
    David
    Staff
    Customer Support

    Can you check the Dashboard > Tools > Site Health and see if there are any issues being raised?

    #1523135
    Aaron

    Site health says, “Warning The optional module, zip, is not installed, or has been disabled.”

    I looked this up, and it looks like GoDaddy (web host) has to take care of that one. Would that be related to the JSON error?

    #1523389
    David
    Staff
    Customer Support

    OK – that issue ‘should not’ be the cause of the issue. But maybe something you want your Host to rectify.

    One thing to try – go to Dashboard > Settings > Permalinks and refresh your Permalinks by simply clicking the Save Changes button a couple of times.

    Then retry updating your page. If that still fails, test to see of their is an issue in the post revisions by creating a New Page and just add the embed code.

    If still an issue then the next thing is to temporarily disable all other plugins aside from GP Premium to see if one them is causing a conflict.

    If that fails then have a chat with your host to make sure the sites Security Permissions allows for mixed content or if using cloudflare its encryption mode is correctly set. They can also check any error logs the site may have generated.

    #1525102
    Aaron

    Ok. I tried all of the above, suggested by David and Leo, and still got the JSON error.

    I called my host, and after they elevated the issue to more knowledgeable people, I spent about 2-1/2 hrs on the phone with them. They opened the firewall, did everything they could with the JSON settings, put me on a previous version of PHP, had me reinstall WordPress, and many other hardware things. Still got the JSON error.

    The last thing I did was install and activate the Classic Editor plugin. That fixed it!

    While I was searching various forums on this issue, I found many are getting this error because of the Gutenberg Editor.

    I’m glad the problem is resolved… I’m not glad to be using the classic editor.

    Thanks for you great support, David and Leo!

    #1525145
    David
    Staff
    Customer Support

    One last option – what if you add the code to a Classic Editor Block ?

    #1525190
    Aaron

    I went to Settings > Writing and changed Default editor for all users to the Classic Block Editor. Then I went to edit the page that contains the podcast embed code, and just clicked Update. The JSON error came back.

    That is the only page that gives the JSON error when Classic Block Editor is on. So I left it in that mode, and if I ever need to edit the podcast page I’ll change it back to Classic Editor Mode.

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.