[Resolved] Images not always rendering from RSS feed

Home Forums Support [Resolved] Images not always rendering from RSS feed

Home Forums Support Images not always rendering from RSS feed

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #1599247

    Featured images from feed displaying in Google News

    This problem has been intermittently present for the last two and a half weeks or so. In Google News search results as well as in our Publisher Centre preview – featured images sometimes show and sometimes do not. On the theme, I have tried both having the ‘show featured images’ ticked on and off through the customiser, neither makes a difference.

    I’ve also tried to use a Code Snippet adding via PHP – this makes no difference either. Even the usually reliable GN Publisher Plugin we use gives inconsistent results.

    One anomoly I have been able to pick up on is that these inconsistencies are only present for searches peformed on desktop – not on my Android phone (not sure about IOS). I suspect this is important and could be something to do with running the site in AMP Standard mode – with a conflict somewhere.

    This is also noticable in how some search of the desktop results are showing with the AMP bolt and others are not – they should all show the bolt since the site runs in standard mode.

    Articles also render correctly in the main feed of Publisher Centre (attached example), which might also suggest there could be a conflict with our permalink structure – since we use a custom structure and not tag/cat.

    One suspicion is that this might have to do with the hero header layout. If that is the case, is there a snippet that can be used to ensure that we keep the current aesthetic but always point to the post’s featured image being the correct one that must be used?

    Lead Developer
    Lead Developer

    Hi there,

    It’s strange that it’s intermittent – it should either work or not, depending on the page.

    Can you link me to one of the posts that sometimes has the image and sometimes doesn’t?

    When you use the Page Hero, it gives you the option to disable the featured image. Doing so removes the static featured image from the post, which might be causing the issue. However, this would always be an issue – not only sometimes.

    You could try enabling the Featured Image in your Header Element and hiding it with CSS – that might fix the issue as the image will be available in the markup.


    Yeah, it’s mad. I don’t actually even have the image hidden in the header as it stands.

    It’s not possible that it’s somehow related to AMP, right? I only ask because of the bolt sometimes showing and sometimes not, even with AMP enabled across everything.

    Also, possibly a shot in the dark, but might the permalink structure have something to do with it? We don’t use the cat/tag at all, so just wondering if that might have something to do with it.

    Not at my computer right now, but will send some links tomorrow.

    But just to add to the mystery: sometimes if I edit the post, literally just by pressing update, it’ll fix itself.

    And the final bit of useless but possibly relevant information… If there is an additional image in the body of the post, it’ll at least grab that as the featured image…… But suspect that’s a WordPress thing.


    I’ve dropped some urls in the private info box…. the only other thing I can think of is that I’ve left a rogue bracket somewhere while making changes.

    There’s also some funny business going on with the RSS feeds [urls also included]

    As mentioned, we use the GN Publisher which has served us well. Some of the feeds it generates have started showing as empty, though (I’m also talking to them to see if they have any inkling about what might be going on). And while their non standard feeds are populated, it’s cutting off the excerpt.
    I thought this might be an issue with child subcategories, but that’s not the case – it’s also only happening sometimes.
    Then I thought it might be with the way I inserted the excerpt hook, but deleted that and no luck.

    My final suspicion is that there is something wonky with the SEO Plugin we use and that it’s not quite following the custom structure correctly somewhere. I noticed that the ‘remove category from your permalink structure’ block was ticked – not sure when I enabled that, but I unticked it to see if there is any difference. Have flushed permalinks and now waiting and seeing.

    Lead Developer
    Lead Developer

    Did you try re-enabling the featured image and hiding it with CSS?

    Using the featured image as a Page Hero background won’t load the image statically, so it won’t be picked up by other sources.

    If the featured image exists on the page (even if it’s hidden), these sources should still be able to pick it up.

    The fact that it’s picking up regular images in the content instead makes me think this is the issue.

    Let me know πŸ™‚


    Happy New Year πŸ™‚

    I haven’t tried that yet actually… can you please share the very basic CSS for doing that?

    Seems some of the recent tweaks I made is working now (don’t ask me which one though… so many… )…. but I’ll keep the CSS bit as another option.

    Lead Developer
    Lead Developer

    Happy New Year!

    How are you currently disabling the static featured image? In your Header Element with the Page Hero, is the “Disable featured image” checkbox checked?

    Let me know πŸ™‚


    Hi to all and happy new year.
    Sorry to break in the middle.
    Only to point one suggestion:
    If you are using the “oficial” AMP plugin, this plugin make a thing called tree-shacking the css aka eliminate css code to fit the 50kb limit, and maybe this the reason the issue is intermitent.


    @Tom – I use the blog module (should I get rid of this rather…? ) and then just leave the display featured images unticked.

    @Longinos – maybe, but CSS limit is well below the recommended AMP limit regardless (not even at 50% usage yet).

    Lead Developer
    Lead Developer

    That’s likely the issue, as it won’t load the featured image anywhere on the page, so the RSS feed doesn’t know to use it.

    You could try enabling them and then hiding them with CSS:

    .featured-image {
        display: none;

    Thanks Tom! I’ll give this a whirl.
    As usual, thank you for your kind help and eternal patience.

    Lead Developer
    Lead Developer

    No problem! Hopefully it fixes it for you πŸ™‚

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.