[Resolved] Image without text

Home Forums Support Image without text

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #575645
    okkarma

    I’m having an issue with images on the home page. I want one large image showing without any text over it all I seem to be able to get is a huge block of content covering it with the image unviewable underneath. I also sprung for the premium pkg but that doesn’t seem to be allowing me to fix things either. Can someone look and tell me what I’m doing incorrectly? Thanks.

    I’d also like to know how to make the menu bar go away if I choose that option and if I do where will the menu appear or can I just not have one?

    GeneratePress 2.1.1
    GP Premium 1.6.2
    #575653
    David
    Staff
    Customer Support

    Hi, the site is password protected, can you release or provide login.

    #575669
    okkarma

    Post my login in the forum? It’s an unviewable beta site. Can I email the user name and pw for it to you?

    #575671
    Tom
    Lead Developer
    Lead Developer

    You can send them through the Account Issue form here: https://generatepress.com/contact/

    Thanks!

    #575691
    David
    Staff
    Customer Support

    Hi Okkarma,

    to add an image over the content there are a couple of options, first off is:

    In the Page Editor > Featured Image. Image’s added here will be the width of the content area.

    If you want to make this image extend the full width of the screen then leave the featured image in place and go to the WP menu > Page Headers.

    Add new Page Header and go to the Content tab and just enter a space.
    Then select Add background image, then choose Container > Full Width and then add some top and bottom padding (for example 300px will make the image 600px high).
    Then go the WP menu > Page Headers > Global Locations and assign your new header to Pages.

    Now whenever you create a new page and assign a featured image that image will be full width above the content. If this works, then you can remove the background image you have set.

    For the Navigation, Go to Appearance > Customiser > Layout > Primary Navigation > Navigation Location > No Navigation. You also have several other choices to place the navigation.

    Let me know if that works.

    #575704
    okkarma

    Sorry, I’m not understanding exactly. I want the image to display as its own portion of the page with nothing under (meaning directly underneath in the same space the image is taking) or over it and I want it to appear on every page of the site that way. The content of the header will be above it and any other content I want to display will be under it (meaning down below it in this case), but nothing over the top of the image or directly underneath it in the same area.

    Not sure why this is so difficult for me to comprehend and implament. Other themes I’ve used just give a place to put an image under the header and it shows up there without being encumbered with text displaying over it (unless you call for it).

    #575709
    David
    Staff
    Customer Support

    The featured image or the page header options provided will do just that. The page will be made up of the header (logo and site identity) followed by navigation, then the featured image (or page header) and then the content area.

    There will be no content over the featured image or page header

    If you want a gap between the image and the content you can do this in the Customiser > Layout > Container > separate containers

    #575712
    okkarma

    Ok, but my WP admin panel and your theme shows no tab option for ‘Page Editor’ so I’m not finding the place you’re telling me to go to try and fix it. Excuse my newby-ness.

    #575713
    David
    Staff
    Customer Support

    Edit the Page itself and to the right hand side you will find the Featured Image option for that page

    #575715
    okkarma

    Thanks but I just checked and the image is already there and was from the beginning. The problem and the original issue I wrote about and had you go look at, is that there is a big block of text and content floating over it when I want nothing over it and want that home page and other page content to appear directly underneath (as in below) the image.

    #575719
    David
    Staff
    Customer Support

    Hi there, i just added a featured image to the home page, here is a view of the page editor. In the bottom right hand corner you will see where the featured image has been added. This now appears above the content. Can you confirm this is correct?

    Featured Image

    #575723
    okkarma

    Yes, I see it there but the featured image, unlike when I’m previewing it, in its live form is floating above another image in the background and the content area below it is not full width so you can see that background image underneath it. This seems like it may take 30 messages and countless hours here to resolve it in this manner when one phone call, when we were both looking at the same screen would have fixed it to begin with in probably five minutes. Just my opinion. I realize you’re not a large company and that’s what attracted me to you to begin with.

    #575732
    David
    Staff
    Customer Support

    To remove the image in the background then go to Appearance > Customiser > Backgrounds > Body and remove the image.

    #575737
    okkarma

    Ok I followed all these steps and the original issue is resolved but really having to create a new header and then assign it and a blank space? Seems like it’s way too complicated for such a simple task accomplishment. Now a few other questions and I’ll go back to leaving you alone.

    1) The word HOME appeared on the home page below the image. What sites do you know that want a big fat HOME appearing above and before their content (and the same for my other pages). Don’t you think the better approach is leave it off and let the user add it in if they simply must have it, instead of spending hours trying to figure out how to make it go away? So that’s my question, how to make these unwanted page titles go away without losing them in the navigation menu in the header?

    2) I don’t know if it’s a function of how I made the body text content stretch to fill the whole screen because you seem to have a default that has a sidebar on each side or something weird like that, but now my content needs margins on the left and right that aren’t there. To put it another way the content is stretching too far across the page.

    3) I have my featured image stretching across the page now after the gyrations I needed to engage in to make it happen but can you also tell me the easiest way to make it taller? I want it to take up more of the page and if it is taller it will also draw people into it more when they are viewing it.

    Many thanks for all your help!

    #575746
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    1. We add the title because it’s important to add an <h1> to your pages for SEO purposes. We also add microdata to this element, which improves your SEO even more.

    You can disable it easily using the Disable Elements metabox inside the Layout metabox while editing that specific page: https://docs.generatepress.com/article/layout-metabox-overview/

    2. It looks like you enabled some sort of full width template inside Beaver Builder. If you disable that option, your content will stay within its container.

    3. You would have to upload an image which is naturally taller. We can use code to force it to be taller, but it will make the image lose quality, and won’t look very good.

Viewing 15 posts - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.