[Support request] Image Display on Chrome Mobile Browser

Home Forums Support Image Display on Chrome Mobile Browser

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1458998
    Richard

    Dear Tom and Colleagues,

    Here’s another new Elementor puzzler.

    Site seems fine with last of both GP and Elementor, except for the mobile Chrome browser, in which many images are not showing up.

    The site is GutsandVictory.com, which is using the Nouveau/Elementor site as the basis.

    Any CSS magic or other fixes would be most appreciated. Not sure why this is only a Chrome fail.

    Thanks.

    Richard

    #1459003
    Leo
    Staff
    Customer Support

    Hi there,

    I just checked the page you’ve linked with my phone and Chrome but not seeing any issues.

    The Chrome mobile simulator tool suggests the same as well.

    Can you try incognito mode and see if the issue is resolved that way?

    #1459076
    Richard

    Hi Leo,

    I tried Incog and same issue (I purged cache in WP too).

    Weird. I tried on wife’s phone on Chrome. It was a OK. And then another phone with Chrome. Not OK.

    They are Samsung Galaxies. S7 and 10.

    Here’s the two screens I get on the home page, one good, one not.

    https://gutsandvictory.com/wp-content/uploads/2020/09/Screenshot_20200925-123944_Chrome.jpg

    https://gutsandvictory.com/wp-content/uploads/2020/09/Screenshot_20200925-123954_Opera.jpg

    It’s a puzzler.

    #1459121
    Leo
    Staff
    Customer Support

    That’s very strange indeed.

    Have you checked with Elementor’s support? The images are loaded from the plugin so maybe they’ve seen similar issues before?

    #1459258
    Richard

    Hi Leo,

    No luck there. Tried some other tech workarounds and no luck there either.

    Perhaps you can add this to the list of Elementor bugs to keep an eye in as you roll out the new GP soon? (This glitch happened in conjunction with me updating the Elementor plugin).

    I’ll just ride it out until then. And do a design workaround then if need be. Thanks.

    Richard

    #1459347
    Leo
    Staff
    Customer Support

    I’m not sure if that’s something we can fix in GP’s end.

    Have you reported this to their support?

    Perhaps they’ve seen this issue before already.

    #1460130
    Richard

    Hi Leo,

    I think I found the issue. All of the unlucky images have this in common, they didn’t load from HTTPS.

    No doubt this isn’t your lane, but I’m a somewhat NOOB and perhaps you can point in the right direction as to find best way fix?

    Here’s what I found during an inspection:

    7Mixed Content: The page at ‘<URL>’ was loaded over HTTPS, but requested an insecure image ‘<URL>’. This content should also be served over HTTPS.

    #1460295
    Tom
    Lead Developer
    Lead Developer

    The best way to change those URLs in bulk is to use a plugin like this: https://wordpress.org/plugins/better-search-replace/

    Then make sure the URLs in “Settings > General” are set to use https so future uploads use the correct protocol.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.