Black Friday Sale! Get up to $30 off GP Premium! Learn more ➝

[Resolved] icons not showing in menu bar on blog page

Home Forums Support [Resolved] icons not showing in menu bar on blog page

Home Forums Support icons not showing in menu bar on blog page

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #455717
    Kin Kok

    Having done the website on my main directory, I am now working on a subdirectory of the website. While icons on the menu in my main directory functions as expected, in the subdirectory, they strangely do not appear on the menu bar of the blog page, but they do appear on the non-blog pages. If I click on the space in which the icons were supposed to be, I would be taken to the page represented by the icon. Any idea what’s going on? How do I fix this?

    GP Premium 1.5.6
    #455833
    Leo
    Staff
    Customer Support

    Hi there,

    The site URL isn’t working. Can you double check?

    #456003
    Kin Kok

    The urls are okay. You probably was trying to get to the sites while I was working on them. Sorry about that. Btw, the icons in the footer of the blog page of the website in the SUBDIRECTORY too do not appear but they do appear in the other pages of the same website. The blog page menu title in the subdirectory is 新闻。It is the second item on the menu bar.

    #456055
    Leo
    Staff
    Customer Support

    Nope the site is still not working.

    Can you double check with address?

    #456077
    Tom
    Lead Developer
    Lead Developer
    #456091
    Kin Kok

    I am a non-techie. I can read the words but I don’t know how to implement the suggested solution. Could you provide a step-by-step implement of a solution? Also, my website goes through Cloudflare. Could the problem be due to that?

    #456095
    Kin Kok

    Btw, the problem is confined only to blog pages and the blog post page but not the other. If the issue is related to CDN, then shouldn’t all pages be similarly affected?

    #456103
    Kin Kok

    Hi Leo, what is your location/time zone? I am located in Singapore (UTC+8). I will try not to work on the websites during your office hours.

    #456307
    Tom
    Lead Developer
    Lead Developer

    Since I can’t actually see the issue, it’s just a guess.

    You would need to place this code in your .htaccess file: https://stackoverflow.com/a/26521650

    The .htaccess file can be edited via FTP or File Manager in your hosting account.

    #456391
    Kin Kok

    Hi Tom, I could grant you access to the websites. Can’t remember how I gave you the password the last time I did that though. Could you remind me?

    Can the code be placed anywhere in the htaccess file or is there a specific location that the code must be inserted into?

    #456392
    Kin Kok

    And have a merry Christmas and a happy New Year!

    #456395
    Kin Kok

    I have added you as an administrator. Please check your email.

    #456433
    Kin Kok

    Currently, all my blog posts uses only the WP editor. For the pages, I use Elementor. I just found out that when I used Elementor to do a blog post, the problems with the icons disappeared. It would appear that I could use this as a workaround for the time being. Still hoping you can provide a direct solution.

    #456490
    Tom
    Lead Developer
    Lead Developer

    Can you make sure the Font Awesome option is turned off in Customize > General? It sounds like you’re loading essentials only.

    If not, it’s likely the htaccess issue, which I can’t help with as it needs to be adjusted on the actual server. You should be able to add it at the very bottom of the file.

    #456787
    Kin Kok

    You are right. After I unchecked the mentioned box, the icons appeared. Issue solved. Thanks very much.

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.