[Resolved] I can´t publish the logo as https but it's working as http

Home Forums Support I can´t publish the logo as https but it's working as http

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1095627
    Jose Antonio

    Hi,
    I have upgrade my website to https protocol from http and I cannot do that the website take the logo picture with the url with https. When I push to select the logo picture the route to reach it is an http address and altough I’ve been trying to discover in the server where is the configuration file to change it by hand, it has been impossible.
    Can you help me?

    I tried to use the solution published in https://generatepress.com/forums/topic/how-to-force-logo-image-to-load-using-https-with-http-site/ but it doesn`t work properly in my website because the logo appear above of all.
    Thanks

    #1095710
    David
    Staff
    Customer Support

    Hi there,

    can you try uploading a new Logo image with a new file name?

    #1096333
    Jose Antonio

    Hi David,
    I’ve been testing again.
    Firstly the logo for the main web didn’t take the correct url with https, but after doing several tests, I have erased the picture, I have upload a new one with different names, etc., I have discovered that the problem appear with the logo for the mobile version.
    I have done the same changes but nothing works.
    The logo and its url is the same for mobile or for computer version.
    Is there any file in the server that I have to modify to put by hand the “s” of https?
    If you say me which it is I could modify it directly.
    Or if you think in other solution I could test it.
    Thanks

    #1096346
    Leo
    Staff
    Customer Support

    You are using the mobile header option so make sure to complete the same steps for the mobile header logo as well:
    https://docs.generatepress.com/article/mobile-header/

    Let me know if this helps 🙂

    #1097975
    Jose Antonio

    Hello again,
    I finally solved the problem.
    The problem appeared when I made the configuration to migrate to https making the changes in the htaccess file and in wordpress wp-config, directly on the server without any plugin.
    So, if you visited the media section, you could see that the url of all media appeared as http in their paths instead of https.
    Thinking about it I decided to remove the configuration in the wp-config file and force the change from the worpress configuration, in General Options. I changed the wordpress url and the site url by typing https there and then the problem was solved.
    It has been strange because previously, in the fields, the urls appeared correctly but nevertheless internally it did not work well.

    Thank you for your comments

    #1098054
    Leo
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.