[Resolved] Home Hero not hiding for Coming Soon mode

Home Forums Support Home Hero not hiding for Coming Soon mode

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #916864
    Miss

    Hi there,

    I’m doing a website re-brand for a client and am using GP Premium together with Elementor.

    I am using the Elementor Maintenance mode tool to show a generic coming soon page with signup form etc.

    On the site I’m working on I’m using the element Home Hero. I have set the display rules to only front page, and Administrator, and I’ve also set the visibility of the element to Private, however, it is still showing up. I also tried logged in users and no joy.

    I have purged entire site and disabled our caching plugin, cleared cache on browser, tried incognito and on phone etc but still no joy.

    The website is https://logjec.co.uk/

    Please can you advise?

    Many thanks in advance,

    Sophie

    #917137
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    I’m able to see the entire page?

    You should be able to hide it with some CSS:

    .elementor-maintenance-mode:not(.logged-in) .page-hero {
        display: none;
    }
    #917402
    Miss

    Hey Tom,

    My hero as always! (No pun intended πŸ˜‰

    Unfortunately, this one didn’t work πŸ™ even when I moved the element to trash it still showed up, but when I click on any of the other links it doesn’t show…

    So I’m guessing it’s server level caching? It’s Nginx do you know anyway around it? I have access to FTP but the ‘etc’ files are hidden and I’m guessing that’s what I need?

    Maybe I could just set up a temporary redirect to a /home blank page for now… The client doesn’t have access to their own hosting as they paid one of these companies who like to keep complete control and charge ridiculous amounts for small changes down the line which is why I’m not using a staging site in the first place as we have no cPanel access to create new SQL etc.

    Thanks so much in advance,

    Sophie

    #917786
    Tom
    Lead Developer
    Lead Developer

    If there is server-side caching, you’ll need to find the correct way to clear it. Maybe this plugin will help?: https://wordpress.org/plugins/nginx-helper/

    #918246
    Miss

    Hey Tom,

    Thanks for this.

    Unfortunately that plugin didn’t work either, however, it is now resolved πŸ™‚

    In case anyone else has similar issues, we were using Hummingbird as the caching plugin before, and although we deactivated it for this exact reason, the caching continued until I reactivated it and specifically disabled the front-page caching from within the plugin.

    Such a simple answer, but I never knew I had to do that or delete the app for the disabling it to actually be effective!

    Thanks so much as always,

    Sophie

    #918713
    Tom
    Lead Developer
    Lead Developer

    Glad you got it working πŸ™‚

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.