[Resolved] Hierarchical Taxonomy archive not showing up

Home Forums Support Hierarchical Taxonomy archive not showing up

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1157069
    Martin

    I have a hierarchical taxonomy called ‘asc’.
    A sample of terms:
    Field Studies (parent)
    –>Arts-Based Facilitation (child)
    –>Dance (child)

    I have used Toolset Types and Views to create the custom taxonomy but when I try to display the archive I created with Views,
    It shows a parent archive fine at:
    https://icasc1a.local/asc/field-studies/

    But the child does not display at (and this is where a linked term points…):
    https://icasc1a.local/asc/field-studies/arts-based-facilitation/

    but I can see it at (if I manually try this):
    https://icasc1a.local/asc/arts-based-facilitation/

    Do you think this is a Toolset issue or something to do with the theme? I’m not sure where to go for help on this one.

    I did try re-saving permalink and switching it from Post name to Plain and back. No change.

    #1157154
    Leo
    Staff
    Customer Support

    Hi there,

    The posts and archive pages are automatically generated by WordPress so I’m guessing it’s some sort of configuration problem between Toolset and WordPress.

    Can you activate a twenty series WP theme and see if the issue still exists?

    If so I’d recommend checking with Toolset’s support to see if they can shed some light on the issue.

    Let me know 🙂

    #1157162
    Martin

    Ok, I’ll check with toolset and let you know.

    Already deactivated all plugins, code snippets and changed to 2020. No dice…

    #1157276
    Martin

    Toolset said:
    Dashboard-> Toolset-> Taxonomies, find and edit taxonomy “ASC!”:
    In section “Options”, enable option “query_var”, save and test again.

    More help:
    https://codex.wordpress.org/Function_Reference/register_taxonomy
    query_var
    (boolean or string) (optional) False to disable the query_var, set as string to use custom query_var instead of default which is $taxonomy, the taxonomy’s “name”. True is not seen as a valid entry and will result in 404 issues.

    Easy peasy.

    #1157338
    Leo
    Staff
    Customer Support

    Awesome.

    Thanks for reporting back 🙂

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.