[Resolved] Hidden featured image

Home Forums Support Hidden featured image

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #81689
    nick

    I would like to hide the featured image on both the posts page and single-post page. I want to do this as a way of setting an image that appears only in recent posts thumbnails.

    The disable elements feature seems to only hide it on the single-post page. How do I hide it completely (but only for specific posts)? I don’t mind if I have to use custom CSS for each instance, as this is not something I expect to use often.

    (In this case, the post contains an embedded tweet with an image, which doesn’t get recognised for my thumbnails but looks just fine on posts page and single-post page. I’ve saved the image separately in my library and just want to be able to manually set it for the purpose of thumbnails—using featured image.)

    Thanks

    #81770
    Tom
    Lead Developer
    Lead Developer

    Hi Nick,

    Give this CSS a try:

    .single .page-header-image-single {
          display: none;
    }

    That should do it 🙂

    #81990
    nick

    It’s likely I’m missing something but that doesn’t seem to do it. Here’s my homepage: http://www.nixwords.com

    The problem is the frog. I want the frog image to appear in the thumbnails on the right, but nowhere else. Do you see what I mean? (I’m still playing around with the layout so I’m willing to go in another direction if this isn’t possible.)

    #81992
    Tom
    Lead Developer
    Lead Developer

    The only place I’m seeing the frog is on the right in the widget? Where else are you seeing it?

    #81994
    nick

    And just to be clear, I basically want to be able to create thumbnails even when there’s no featured image visible to the reader. But I still want featured images to appear by default on regular posts.

    One solution that works is to use excerpts on the blog page so that the embedded tweet thing doesn’t show or to somehow filter the thumbnail section to exclude these types of posts, but it would be great if I could have it all…

    #81995
    nick

    Oh, really? I see it twice on the blog post.

    #81998
    Tom
    Lead Developer
    Lead Developer

    Try clearing your browser cache – it should be hidden.

    #82003
    nick

    I mean on the homepage, the blog page. The featured image shows above the embedded tweet.

    I don’t want to turn off featured images on single posts—I can do that by disabling elements on a post-by-post basis, which is fine. I want to turn it off for the main blog page (sorry about my confusing use of terms) but still have it visible to widgets etc.

    #82009
    Tom
    Lead Developer
    Lead Developer

    Gotcha.. So you want to keep most post images on the blog, but this particular one is doubled by the twitter image.

    Each post has a unique ID you can find by using Chrome’s Inspect Element or Firefox’s Firebug.

    For this specific post, you can do this:

    #post-351 .post-image {
          display: none;
    }
    #82010
    nick

    Brilliant, yes that’s exactly what I want. Thanks so much. (And I’m an Apple fanboy so I’m using the web inspector in Safari…)

    #82011
    Tom
    Lead Developer
    Lead Developer
    #414643
    pankaj

    Hello tom,

    As you specified it disable feature image in post…not pages…I have inserted that css…how to disable feature image on pages???

    #414658
    Leo
    Staff
    Customer Support

    Hi there,

    It would be:

    .page .page-header-image-single {
          display: none;
    }
    #414818
    pankaj

    ok thanks

    #415031
    Leo
    Staff
    Customer Support
Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.