[Support request] Help – posts and categories suddenly won’t display

Home Forums Support Help – posts and categories suddenly won’t display

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1350951
    paddyd

    I don’t know what is going on – this happened suddenly. All I’d done was enable Fluent contact form and created a new form, then found that all the posts and category pages were loading completely blank except for the header, menu and title and featured image, on the post pages and header and menu on the category pages.

    The posts are all still there – I can open one in edit mode and it’s fine – but it will not display when not in edit mode.

    I tossed out Fluent – no change. Turned off all plugins – posts were again visible. Turned on GP Premium…they disappeared again. I’ve left it with GP Premium, WP Show Posts & WP Show Posts Pro (neither of which affect the visibility issue – I’ve tried those on and off etc.) so that you can see this. I think I have a backup (Acronis runs daily on the site in Cpanel) but before I just restore from that, assuming I can, I would like to know what the heck is going on, since the problem seems to be related to GP Premium.

    Please have a look – https://muskokastyle.com/test1/ – if you need login credentials, please let me know.

    We were about to go live with this site…

    #1350998
    paddyd

    Well…with a little help from my host (Crocweb) I was able to sort this out. I’d deleted the Subtitle plugin – but apparently doing that caused the GP element I’d created to enable it to show properly to throw a major error. Here’s the log:

    [03-Jul-2020 19:46:09 UTC] PHP Fatal error: Uncaught Error: Call to undefined function the_subtitle() in /home/muskoka/public_html/test1/wp-content/plugins/gp-premium/elements/class-hooks.php(180) : eval()’d code:1
    Stack trace:
    #0 /home/muskoka/public_html/test1/wp-content/plugins/gp-premium/elements/class-hooks.php(180): eval()
    #1 /home/muskoka/public_html/test1/wp-includes/class-wp-hook.php(287): GeneratePress_Hook->execute_hook(”)
    #2 /home/muskoka/public_html/test1/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(”, Array)
    #3 /home/muskoka/public_html/test1/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #4 /home/muskoka/public_html/test1/wp-content/themes/generatepress/content.php(43): do_action(‘generate_after_…’)
    #5 /home/muskoka/public_html/test1/wp-includes/template.php(725): require(‘/home/muskoka/p…’)
    #6 /home/muskoka/public_html/test1/wp-includes/template.php(672): load_template(‘/home/muskoka/p…’, false)
    #7 /home/muskoka/public_html/test1/wp-includes/general-template.php(168): locate_template(Array, true, false)
    #8 in /home/muskoka/public_html/test1/wp-content/plugins/gp-premium/elements/class-hooks.php(180) : eval()’d code on line 1

    So – trashed the subtitle element I’d created and everything is now working again. The installation of Fluent Forms was a red herring – I did that just after I deleted the un-needed plugins.

    But an interesting thing to note – if you create elements to deal with the display of plugin output and then delete the plugin, something nasty might happen, apparently.

    #1351047
    Leo
    Staff
    Customer Support

    Hi there,

    Sounds like it’s all good now?

    #1351082
    paddyd

    Yeah – it’s all fixed now. I just wondered if that is “expected” behaviour if one removes a plugin without remembering to remove the associated element/function? I’m guessing it would depend a bit on when the PHP executed, and what it did – but might be worthwhile to remind people that if they are using a plugin that requires an element or even a PHP snippet, that they should be sure to delete the element or snippet before they delete the plugin. 😉 That was a pretty alarming result, LOL…

    #1351213
    Leo
    Staff
    Customer Support

    Glad you’ve fixed it 🙂

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.