[Support request] Header dont go under the custom header (Page Header)

Home Forums Support [Support request] Header dont go under the custom header (Page Header)

Home Forums Support Header dont go under the custom header (Page Header)

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #488852

    Hi! I create a custom header with your add-on. But the plugin I’m using kind of corrupt the viewport when I activated the header on my page.
    I arrange slightly the issue by adding this CSS, but I still don’t have the slider under the menu.

    .generate-combined-page-header {
        height: 0vh !important;

    Can you help me found out what I can do for this issue?

    GeneratePress 2.0.2
    GP Premium 1.5.6
    Customer Support

    Hi there,

    Not sure you mean by kind of corrupting the viewport?

    Are you adding the slider shortcode inside page header content?


    No, I put the shortcode inside the page section. I’m using a plugin that gives you the possibility to create section that you can’t put inside a fullpage container. That plugin uses a template page that has no <?php get header /?php> so I had one ( I used your code in the single.php files).

     * The template for displaying all fullpages
     * This is the template that displays all fullpages by default.
     * Please note that this is the WP Fullpage construct of fullpages and that
     * other 'pages' on your WordPress site will use a different template.
    get_header(); ?>
    	<div id="primary" <?php generate_content_class();?>>
    		<main id="main" <?php generate_main_class(); ?>> // This part is add 
    <div id="fullpage" class="<?php WPFP_Query()->get_fullpage_easing(); ?> <?php print WPFP_Query()->fullpage->post_name; ?>" data-bg="<?php print WPFP_Query()->get_fullpage_bg(); ?>">
    		while ( have_posts() ) : the_post();
    			// Start the sections Loop.
    </div><!-- #fullpage -->
    $navigation = WPFP_Query()->fullpage->fullpage_options['navigation'];
    if( 'yes' === $navigation )
    // WPFP()->get_sidebar();

    Maybe I forgot to add some code to my template that creates this conflict.

    This is the original parameter after I activate the custom header
    .generate-combined-page-header {
    height: 100vh;
    But when I leave this as it is, the fullpage scroll is blocked by this parameter.
    It’s a plugin conflict for sure, but it’s the only way I found out to implant the fullpage.js in WordPress. Can you help to find a solution ?

    Lead Developer
    Lead Developer

    I don’t really see the issue, but perhaps try this instead?:

    .generate-combined-page-header {
        height: auto !important;

    You can also just de-select the full screen option in the Page Header settings.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.