[Support request] Has anyone updated to GP2.0 Alpha.2 on a live site yet?

Home Forums Support Has anyone updated to GP2.0 Alpha.2 on a live site yet?

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1675721
    Catherine

    Wordfence is driving me nuts because of the update available in the plugin dashboard.

    Just wondered if anyone has actually bitten the bullet and updated on a live site with Alpha.2?

    I don’t have a staging area, plus, GP 2.0 looks pretty tempting to just get in there, lol.

    Many thanks

    #1675851
    David
    Staff
    Customer Support

    Hi there,

    i am sure there are plenty of users who have – but we don’t personally recommend doing so in case there are any ‘bugs’ that could cause breaking changes.

    #1675897
    Catherine

    I’ve made a backup – I’ll let you know how it goes!

    #1676309
    David
    Staff
    Customer Support

    Be great to get your feedback πŸ™‚

    #1678559
    Catherine

    Hi there!

    So I have gone live with GP2.0 Alpha.2 and also added the Generate Blocks plugin.

    Initially I just tried the free version of GB but I needed more functionality and pre-designed templates because I’m not a designer.. so I upgraded to Pro. Nice!

    I had no issues trying out the free version of GB but I did come across a couple of issues working with the Pro verson of the plugin, but nothing that was lasting.

    On one occaision I was trying to add Info Boxes 6 and the whole editor just disappeared. This included the content, the actual editor and the setting of Full Screen was gone. I went back to the page by clicking on Pages and navigated to the page. It loaded fine and did not repeat that blip for the rest of the session. WordPress had taken autosave on crashing but I wanted to see if adding the Info Box was the issue so I didn’t restore the autosave created another container and so on.

    On two other occaisions, trying to add the colours for the container background gradients, the pop up colour selector got locked in a flickering state.

    One of those occaisions was to copy the colour hexidecimal value. I was able to highlight it during the flickering but on pasting it into another box, the copy hadn’t worked. I went back to the hexidecimal value and the colour box was not flickering this time.

    The second occaision of flickering with the colour selection pop I was just going to add a value. I came out of that selection and went back into it with no issue and no more flickering.

    I haven’t experienced any further issues while playing around this morning and I have built my new homepage using GP2.0 Alpha.2 with GB Pro. I haven’t quite finished it yet because I have some work to do on the footer but it’s good to go for now.

    I hope that helps with troubleshooting and ironing out any final bugs before GP2.0 goes live properly. For reference, on activating GP2.0, I went over my site and clicked on many live pages and the backend and I saw no other issues. Looking good!

    #1679761
    Elvin
    Staff
    Customer Support

    Hi there,

    Thank you for the write up. We sincerely appreciate these kinds of replies as these defintely push the theme and the plugin to be something better. πŸ™‚

    Any chance you could share your site details? Ex: WordPress Version, GeneratePress theme version, plugins used, etc?

    This is so we could try and replicate the issues mentioned to confirm if it is actually a bug or it’s a user’s site specific issue. Thanks.

    A wise man once said:
    "Have you cleared your cache?"

    #1679919
    Catherine

    Hi there,

    I also am aware that the little laptop I’m on may also have some limitations. It’s a nice little thing but it’s not my main desktop, which is currently being used elsewhere.

    Details as follows:

    WordPressL 5.6.2

    404page – your smart custom 404 error page (inactive)
    Add Widget After Content 2.4.2.
    Akismet 4.1.8 (update became available overnight 4.1.9)
    Autoptimize 2.8.1
    BBQ Firewall 20210211
    Better Click to Tweet 5.10.0
    Cache Enabler Version 1.6.2
    CAOS Version 3.9.2
    Change Table Prefix 2.0
    Classic Editor 1.6
    CloudFlare 4.2.0
    Cloudinary 2.6.0 (inactive)
    Code Snippets 2.14.0
    Disable Emojis (GDPR friendly) Version 1.7.2
    Email Address Encoder 1.0.22
    Far Future Exploration Plugin 1.4
    Fast Velocity Minify 3.1.4
    Generate Blocks 3.1.4
    Generate Blocks Pro 1.0.2
    Generate Premium Version 2.0.0-alpha.2
    Insert Headers & Footers 1.5.0
    Jetpack by WordPress.com 9.4 (update became available overnight 9.5)
    Lazy Load – Optimize Images 2.3.4
    Lazy Load for Comments 1.0.10
    Limit Login Attempts Reloaded 2.19.2 (update became available overnight 2.20.2)
    Mailchimp 1.5.7
    Meks Easy Social Share 1.2.2
    Patreon WordPress 1.7.1
    Plugin Logic 1.0.7
    Redirection 5.0.1
    Similar Posts 3.1.3
    Simple Sitemap 3.5.2
    The SEO Framework 4.1.3
    UpdraftPlus Backup/Restore 1.16.47
    Wordfence Security 7.4.14 (free version)
    WP Cloudflare Super Page Cache 4.4.4
    WP Htaccess Editor 1.67
    WP-Optimize – Clean, Compress, Cache 3.1.7 (used to optimize database)

    Generate Press Theme 3.0.2 (update became available overnight 3.03)

    I haven’t done any of the updates this morning, thought I’d wait until one of you gave me the nod. I happy to let one of you login to my dashboard if you want a closer look. I don’t have every setting enabled in every plugin. I follow pagepipe.com for site optimization and their advice for plugins and which settings to enable, or not. Page Pipe is where I first learnt about Generate Press πŸ™‚

    Many thanks.

    #1680045
    David
    Staff
    Customer Support

    That type of issue sounds like a potential ‘limitation’ of the device.
    The Editor is built using React and there are a lot of state changes occurring when any element is interacted with … which requires quite a reasonable amount of CPU processing power / memory.

    Are you able to replicate the issue on your desktop device?

    #1680061
    Catherine

    Hi there,

    I’m not able to access it until this evening so I will have a play around later and report back any issues.

    Many thanks!

    #1680155
    David
    Staff
    Customer Support

    Thank you – we really appreciate you taking the time to test!

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.