[Resolved] H1 Tag Missing

Home Forums Support H1 Tag Missing

  • This topic has 13 replies, 3 voices, and was last updated 4 months ago by David.
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1249141
    Laurie

    Hello,
    I have recently started using wordPress and your theme and launched a site recently, I have added it to bing webmaster and have received the seo analysis as below. This relates to H1 tags which it says are missing? I was under the impretion that the H1 tag was automaically applied using the page title? – Could you please confirm if this is the case of if I need to add them somehow. Ironically, I was searing for the H1 tags setting in the configuration setting and as I could not find them or any styling for H11 assumed that this was generated as mentioned above., this is

    “SEO Analysis Detail (Beta)
    SEO Suggestion The <h1> tag is missing.
    Severity High
    Error Count 6
    Non-Compliant Pages 6
    SEO Explanation The <h1> tag is an indicator to Bingbot and web visitors of what the body copy’s primary theme or topic is. The <h1> tag reinforces the core keyword(s) found in the title, description, and the body copy. We recommend that the <h1> tag includes keywords that reflect the contents of the page and that it is not longer than approximately 150 characters in length.
    Recommended Action Add a header to the page by using a <h1> tag and place it within the <body> of the page source. Example: <h1>A precise and descriptive headline for the page</h1>.

    Many thanks for your help, (as ever),

    Best regards

    L

    #1249506
    Leo
    Staff
    Customer Support

    Hi there,

    The page title should be <h1> by default but looks like you’ve hidden the page title in the page linked?

    #1250542
    Laurie

    Hello, thank you for the reply; yes you are quite right, I did “hide page titles”, I did wonder about that and did google it, being new to wp, I guess I made the wrong decision to hide the page title on all pages.

    Thank you for your guidance, is there any way I can change the pages without opening each page or will I have to open every the page and set them individually?

    Many thanks again for your help.

    #1250880
    David
    Staff
    Customer Support

    Hi there,

    simplest way would be to edit each page to make those changes…. how many do you have to edit, hope its not too many 🙂

    #1251104
    Laurie

    Hello David, Thank you for your response, I thought I would have to do them all individually, I did look on google and it seemed the best way; Not too many pages though, 3156 in total! – it’s a job for Auto Hot Key!

    I’ll get on with it then!
    Many thanks again, speak soon,
    Bye for now
    L

    #1251119
    David
    Staff
    Customer Support

    Oh my – good luck with that 🙂

    #1253574
    Laurie

    Hello again,
    Sorry to trouble you again, I have just completed what I thought was required to enable the h1 site title to be shown |(for search engines) and noticed that I might have checked the wrong option to enable the H1 tag to enable google and bing to index the pages.

    Could you please confirm which is the option to enable H1 tags as you recommend, is it the “Hide page Title” checkbox in the “settings” section for each page or the option to “Show Content Title” in the text box on the page (where I enter the page title)?

    I thought I had better clarify if I have done it correctly!

    many thanks again for your help

    #1254724
    David
    Staff
    Customer Support

    Both of these option do the same thing – you will notice clicking the eye icon changes the checkbox in the Disable Elements Meta Box.

    #1261152
    Laurie

    Hello David,

    Thank you for the update, I will have a play!

    Bye for now, thank your for your help.

    Best regards
    L

    #1261425
    David
    Staff
    Customer Support
    #1283619
    Laurie

    hello
    I hope you are all well, I am persevering and trying to get my site indexed and thought I would update!

    I have followed the much-appreciated guidance and now have ensured that all pages have their H1 tags not hidden and all are showing in the pages.

    The site is still not ranking, although I do appreciate it can take time, I notice that pages that I had previously ranking well before rebuilding the site in WordPress are no longer showing at all on google, I have checked in google search console and am getting various results when doing a URL inspection including;

    URL is not on google

    noindex

    I also noticed this layout change morning in the published site?

    I had created a “link page” listing all the pages to hopefully help search engines find the pages, I had two different styles of pages, one that was created just linking descriptive text to the relevant page and another using a plugin to create the page links.

    When today, I was trying to find problems I noticed that both pages were no longer formatted as they were before. The links that were on one page have been split into several hundred pages and now include descriptive text under each link.

    Please see links/images below,
    Below as designed and envisage (and format that was previously showing;
    https://grantschemes.co.uk/wp-content/uploads/2020/05/as-produced-text-links.jpg

    And as they are now?
    https://grantschemes.co.uk/areas-boilers/
    https://grantschemes.co.uk/wp-content/uploads/2020/05/as-appearing-now-text-links.jpg

    I am guessing that this must be happening because of some settings but I have looked and cannot see where this may be controlled.

    I would appreciate any help. Many thanks

    L

    #1284056
    David
    Staff
    Customer Support

    Hi there,

    looks like that post has a slug of areas-boilers but you also have a category with that same slug. In this case the URL is going to the Category Archive. You would need to change the slug on your page to stop that conflict.

    #1285608
    Laurie

    Hello,
    Many thanks for your help, I would never have found the conflict!
    have a good weekend
    Best regards

    L

    #1285630
    David
    Staff
    Customer Support
Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.