Premium support

Please log in to post in these forums. If you didn't create an account when you purchased, please contact us.

Free support

If you haven't purchased GP Premium, support for the free theme can be found on WordPress.org.

[Resolved] GP Typography -- memory error

Home Forums Support GP Typography -- memory error

This topic contains 5 replies, has 2 voices, and was last updated by  Tom 3 years, 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #3916

    Hi Tom,
    I updated the Typography plug-in from version 0.4 to 0.6 — now I can’t access the design > customize section.
    I Receive a error message reading:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 32 bytes) in /var/www/web1158/html/wp-content/plugins/generate-typography/customizer/google-font-dropdown-custom-control.php on line 76

    How do I solve that problem?

    I use Generate Press 1.0.9; the problem occurs with Firefox and Safari.

    Thanks for your help,
    Boris

    #3956

    Tom
    Lead Developer

    Hi Boris,

    Ah – this is happening because the list is trying to list every Google Font – I may have to limit the list in the next version.

    You can increase the amount of memory you’re aloud to fix this issue.

    http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    Let me know if you need more help,
    Tom

    #3977

    Hi Tom,

    thanks for your help. I tried to follow your instructions. I copied the following lines into wp-config.php (after the language info [define(‘WPLANG’, ‘de_DE’);] and before the debugging mode line [define(‘WP_DEBUG’, false);]:

    define(‘WPLANG’, ‘de_DE’);

    /**
    * Boris Typography-Problem
    * Increasing memory allocated to PHP
    */
    define(‘WP_MEMORY_LIMIT’, ’96M’);

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define(‘WP_DEBUG’, false);

    I restarted Firefox, logged into my WordPress site, clicked on the Design > Customize button — and got the same error message as before:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 64 bytes) in /var/www/web1158/html/wp-content/plugins/generate-typography/customizer/google-font-dropdown-custom-control.php on line 76

    What did I do wrong?

    Boris

    #4009

    Tom
    Lead Developer

    Hi Boris,

    Who are you hosted with?

    You can try calling them and asking if they can increase your memory limit in your php.ini (unless you have access to this file and know how to change it).

    If they won’t, you can email me at support@generatepress.com with your URL, username and password and I’ll fiddle around to make it work.

    Let me know – we’ll get this sorted out for you 🙂
    Tom

    #4057

    Hello Tom,

    great it works! The provider is a german one based in Leipzig, called alfahosting. I called them — and they showed me how I could increase the memory via the customer center. Now the maximum 64 M are chosen.

    Thank you very much for your support and help!
    It was a good feeling knowing that you were ready to take over.

    Glad greeting from

    Boris

    #4067

    Tom
    Lead Developer

    Excellent!

    Tom

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.