[Support request] GP Premium 1.6.2 Causes Template Creation in Elementor 2.0 Pro to Hang

Home Forums Support [Support request] GP Premium 1.6.2 Causes Template Creation in Elementor 2.0 Pro to Hang

Home Forums Support GP Premium 1.6.2 Causes Template Creation in Elementor 2.0 Pro to Hang

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #603989
    Josh

    I also submitted this ticket to Elementor:

    When trying to create certain template types under ‘My Templates > Add New’, Elementor 2.0 Pro will:

    – start the creation process
    – a green progress line will run halfway over the top of the browser
    – the Library popup that allows us choose the premade templates does not come up
    – the screen then hangs on the ‘E’ symbol indefinitely

    The URL in the browser bar of Chrome shows this URL:
    https://[MY SITE].com/wp-admin/post.php?post=[POST ID HERE]&action=elementor#library

    Template types this happens with:

    – Single (Post or Page)
    – Page
    – Archive

    What I tried in order to debug this:

    – cleared cache and cookies in Chrome
    – verified server PHP 7.1
    – verified server memory at 128MB
    – d/led site to localhost, tried here
    – deactivated all plugins but E and Epro on localhost, then added them back one by one trying to create a Single Post Template

    It turns out the GP Premium vs 1.6.2 is the problem plugin. When it’s deactivated the library will load and I can choose the library templates.

    Note that I did the troubleshooting on localhost. Then I deactivated GP Premium on the server copy and again… the library popup loaded fine.

    This plugin is central to the functionality and features of the website in question as well as all of my client websites currently. I reported this Elementor as well. I sent them the system information of the server copy in question, so let me know if you want to see that! Thanks!

    GeneratePress 2.1.2
    GP Premium 1.6.2
    #604052
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    That’s strange – we haven’t received any other reports of issues.

    If you deactivate your GPP modules one by one (Appearance > GeneratePress), does it begin to work? If so, which module is causing the issue?

    #604220
    Josh

    I found it.

    – deactivated each module in turn
    – tested
    – reactivated that module
    – etc down the list

    The Library popup came up when I deactivated the Hooks module.

    I then checked my Hooks. I’m using the Hooks module to put in

    – Before Header – site header & nav from Elementor template shortcodes
    – Before Footer Content – a ‘footer area’ with a CTA form for the bottom of the page

    The footer area is using some conditional code to put different styled forms on different pages.

    When I pulled out the code from Before Footer Content, the issue went away.

    Here’s the code:

    <?php if ( is_page( array( 2420, 5430 ) ) ) : ?>
        [elementor-template id="5467"]
        [elementor-template id="5474"]
    <?php endif; ?>
    
    <?php if ( is_page( array( 2425, 2529, 2528, 2527, 4386, 2779, 2528, 2524 ) ) ) : ?>
        [elementor-template id="3662"]
        [elementor-template id="5028"]
    <?php endif; ?>

    I also tried leaving the code in the Hook and unchecking ‘Run PHP’ to see if that was the issue. It seems to be the code itself…thanks…

    #604528
    Tom
    Lead Developer
    Lead Developer

    So what happens if you keep the PHP, and remove the Elementor shortcodes?

    I believe I’ve seen this before, and it was some sort of conflict within the Elementor shortcode and their own plugin. If removing the shortcodes fixes the issue, you’ll definitely want to report this to their support team.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.