[Support request] Google mobile friendly test fails

Home Forums Support Google mobile friendly test fails

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #935494
    Inge

    Hello,
    So Google search console states that my website has tons of non mobile friendly pages.
    It says clickable elements are too close together and content is wider than the screen.
    I know this is not the case since the pages look perfect on mobile.

    This issue is due to the fact that css is not loaded by the mobile testing tool.

    It says: resources not loaded (reason: other)

    See one of the result pages here: https://search.google.com/test/mobile-friendly?hl=nl&id=8ntGITXu3RzitErTUhkVtQ

    I tried everything I could: css is combined and minified, goog bot has access to all files, etc.

    How can this be fixed?

    I’m afraid that if Google says our pages are not useable for mobile, our rankings will drop.

    Awaiting insightful replies πŸ˜‰

    #935564
    David
    Staff
    Customer Support

    Hi there,

    i looked at your landing page and there are 141 requests being made, 61 of which are being flagged up on the mobile friendly test as an error or warning.

    So no matter how well optimized the site may be, you have probably way exceeded the Request Quota that google sets hence why its just not loading most of the assets.

    I would suggest you look at significantly reducing the number of requests being made.

    #935566
    Inge

    Hey David,

    Thanks for your reply

    How do you actually do that? Because I have no idea why that is…

    Thanks

    #935579
    David
    Staff
    Customer Support

    Minimizing the requests – first is to try combining stylesheets and javascript – our optimization tips will help:

    https://generatepress.com/fastest-wordpress-theme/

    I see you’re using SG Optimizer which provides the same options, but it does sometimes cause a few issues and generally i discard it for Autoptimize.

    Next is to look at any plugins that are making requests for external scripts or CSS, as these cant and won’t be combined.
    Check the Waterfall on this GTMetrix report:

    https://gtmetrix.com/reports/onlyonce.today/MnP8XS8a

    You will see the Domain where the requests are being made – look to minimize these requests by reducing your needs e.g do you need all those google fonts, what are the secure gravatars doing and what am i using that requires so many facebook scripts.

    #935665
    Inge

    All right!
    Thanks for your insightful comment!

    I did everything you said straight away:
    ditched SG optimizer for autoptimize (this one didn’t work with our previous theme), removed the Facebook scripts, disabled gravatars, and loads of other stuff.
    We now only have 58 http requests! Jeej! (variable per post)

    But still not mobile friendly πŸ™

    I’m very happy with the results of this effort, but I need Google to see our pages as mobile friendly…

    #935924
    David
    Staff
    Customer Support

    I just ran a test on the home page and it passed πŸ™‚
    If you update the Theme to GeneratePress 2.3 ( latest version ) then in Customizer > General – you can change Icon Type to SVG this will remove a couple more requests.

    Aside of that to improve performance is to look at what else you can remove from the pages to minimize requests – images, fonts etc….

    #935974
    Inge

    I know!
    I did quite a few other things as well!

    I’m actually trying this plugin: Autoptimize CriticalCSS.com Power-Up
    But I don’t know yet if I like it πŸ™‚

    I will definitely try these settings you suggested later today!

    Thanks for your help!

    #935981
    David
    Staff
    Customer Support

    Glad to be of help πŸ™‚

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.