[Support request] Google fonts called via http instead of https

Home Forums Support Google fonts called via http instead of https

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #302099
    Christoph

    Hi,
    I am getting the following error in my browser console when calling any backend page:

    Mixed Content: The page at 'https://mydomain.net/wp-admin/index.php' was loaded over HTTPS, but requested an insecure stylesheet 'http://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700&ver=6f8d69770c7c567b895ad9d598239c4d'. This request has been blocked; the content must be served over HTTPS.

    Now, I know that you have stated elsewhere that generatepress is calling google fonts as //fonts…, thus avoiding this error. However, the font that is being called here is Open Font (the default GP font), I am posting my request here because I suspect that maybe it is a problem GP nevertheless? (Although I’m not sure why the error would occur only in the back-end and not in the front-end.)

    I checked line 56 of /wp-admin/index.php but I have no idea why the error is supoosed to originate there because line 56 says:

    $help .= '<p>' . __( '<strong>Screen Options</strong> &mdash; Use the Screen Options tab to choose which Dashboard boxes to show.' ) . '</p>';

    I have no idea where else to look…

    GeneratePress 1.3.46
    #302158
    Tom
    Lead Developer
    Lead Developer

    I’m assuming that call is coming from a plugin. GP doesn’t add a version like that.

    Might be worth deactivating plugins one by one to see if it goes away when one gets deactivated.

    #935310
    Henry

    Hi Tom,

    My website (https://www.primarypointe.com/) has been giving me these error as well. It is a recent site and it was displaying fine for the first couple of days then today I noticed the drop down menu started to look weird (no new plugins installed) so after checking the console I noticed the font errors. I have disabled all plugins one by one but could not resolve. Below are the errors. Any help would be appreciated. Thanks!

    Mixed Content: The page at '<URL>' was loaded over HTTPS, but requested an insecure font '<URL>'. This request has been blocked; the content must be served over HTTPS.
    VM417:1 Mixed Content: The page at 'https://www.primarypointe.com/' was loaded over HTTPS, but requested an insecure font 'http://www.primarypointe.com/wp-content/themes/generatepress/fonts/generatepress.woff2'. This request has been blocked; the content must be served over HTTPS.
    VM417:1 Mixed Content: The page at 'https://www.primarypointe.com/' was loaded over HTTPS, but requested an insecure font 'http://www.primarypointe.com/wp-content/themes/generatepress/fonts/generatepress.woff'. This request has been blocked; the content must be served over HTTPS.
    VM417:1 Mixed Content: The page at 'https://www.primarypointe.com/' was loaded over HTTPS, but requested an insecure font 'http://www.primarypointe.com/wp-content/themes/generatepress/fonts/generatepress.ttf'. This request has been blocked; the content must be served over HTTPS.
    (index):1 Mixed Content: The page at 'https://www.primarypointe.com/' was loaded over HTTPS, but requested an insecure font 'http://www.primarypointe.com/wp-content/themes/generatepress/fonts/generatepress.woff2'. This request has been blocked; the content must be served over HTTPS.
    (index):1 Mixed Content: The page at 'https://www.primarypointe.com/' was loaded over HTTPS, but requested an insecure font 'http://www.primarypointe.com/wp-content/themes/generatepress/fonts/generatepress.woff'. This request has been blocked; the content must be served over HTTPS.
    (index):1 Mixed Content: The page at 'https://www.primarypointe.com/' was loaded over HTTPS, but requested an insecure font 'http://www.primarypointe.com/wp-content/themes/generatepress/fonts/generatepress.ttf'. This request has been blocked; the content must be served over HTTPS.
    #935995
    David
    Staff
    Customer Support

    Hi there,

    that looks like an SSL was added after the plugin was installed, rebuilding URLs with a plugin like Velvet Blues Update URLs should resolve that.

    Alternatively if you’re using the latest version of the GP Theme 2.3 in Customizer > General you can now chose SVG Icons which eliminates the need for the font. Just be mindful if you have used these fonts in your own HTML they won’t work anymore.

    #936103
    Henry

    Thank you! David. I used Velvet Blues Update URLs but it found no URLs that needed to be changed. However, changing the Icon type to SVG did work! Thank you!

    #936115
    David
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.