[Support request] Google analytics not firing on Course Pages

Home Forums Support [Support request] Google analytics not firing on Course Pages

Home Forums Support Google analytics not firing on Course Pages

  • This topic has 9 replies, 3 voices, and was last updated 4 weeks ago by Elvin.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #2053087
    Mike

    HI,

    I can not see the course pages (lessons and topics) in the google analytics. I have the tag implemented firing on all page views, but it appears when entering a lesson, the header disappears, removing the google analytics tag. Is there a way to solve this?

    #2053222
    Ying
    Staff
    Customer Support

    Hi Mike,

    I’m not sure I follow your question, can you explain a bit more?

    And can you share some links where we can see the issue?

    #2053273
    Mike

    Hi Ying,

    I have a google analytics code installed on my website. http://www.cryptogurus.io. It works on every page, except when a user signs up for a course.

    For example, when a student is on the cryptocurrency topic in the first lesson, https://cryptogurus.io/topic/what-is-cryptocurrency/ , The google analytics snippet is not firing on any page within the course. You can use the chrome extension, google tag assistant, to see that google analytics code is not on the page.

    Best,
    Mike

    #2053318
    Ying
    Staff
    Customer Support

    How did you add the google analytics code?

    #2053331
    Mike

    I have analytics firing through google tag manager. I copied and pasted the tag manager codes in the respective place into the header.php file. One after the head tag and one after the body tag. If you look at the page source on the homepage, you can search for “GTM” and see where they are placed.

    #2053337
    Ying
    Staff
    Customer Support

    I installed the extension, and seems the code is there:
    https://www.screencast.com/t/dHCdh6lZ2

    Did I miss anything?

    #2053385
    Mike

    Okay I see the disconnect.

    Once a user registers for a course, I lose the analytics tag. As of now, it set to “free” requiring an email to login.

    Please register as user and run the tag assistant when your taking the course. It is removed from the site. For example in the screenshot, there are 4 topics in the cryptocurrency lesson. If you are taking any one of those topics in the lesson, the google tag manager code is removed.

    #2053996
    Elvin
    Staff
    Customer Support

    Hi there,

    All the pages return this error – https://share.getcloudapp.com/P8u60Ayo

    You can refer to the following to get the details about the addressing them.
    https://support.google.com/tagassistant/answer/3059154?ref_topic=2947092#missing_property
    https://support.google.com/tagassistant/answer/3059154#http_response

    A wise man once said:
    "Have you cleared your cache?"

    #2054014
    Mike

    What interesting is that is not my tracking code. I am not sure what the one refers to, but you can see that when logging in as a student, it removes the original Google Analytics code. See the prior picture from Ying.

    Do you have a recommended Google Tag manager plugin to work with for generatepress?

    #2054127
    Elvin
    Staff
    Customer Support

    Google’s site kit should work w/ GeneratePress. 😀
    https://en-ca.wordpress.org/plugins/google-site-kit/

    A wise man once said:
    "Have you cleared your cache?"

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.