[Resolved] Global body-Settings with a specific space

Home Forums Support Global body-Settings with a specific space

This topic contains 19 replies, has 3 voices, and was last updated by  Leo 1 month, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #1183117

    sporenborg

    Hi,

    is there a way to set the global body settings, for example to 5%, to all sidelines for all areas incl. all responsive breaks? In my example (blog post) you can see the landscape tablet view has 0 space to the left sideline. I can’t imagine that the settings of the GP theme have to be realized exclusively via the design / customizer / css settings.

    The widget areas are fine. But the blog content behaves completely different from header and footer.

    Thank you in advance.

    #1183433

    David Customer Support

    Hi there,

    if you want to use % padding across the various site containers then try this CSS:

    .inside-header,
    .separate-containers .inside-article,
    .separate-containers .comments-area,
    .separate-containers .page-header,
    .separate-containers .paging-navigation,
    .one-container .site-content,
    .inside-page-header,
    .wp-block-group__inner-container,
    .widget-area .widget,
    .footer-widgets
     {
        padding: 5% !important;
    }
    #1184603

    sporenborg

    Hi David,

    thank you! You mentioned the “various site containers”. Is there an easier way to set-up these paddings I didn’t see?

    Thank you!

    #1184626

    David Customer Support

    In the Customizer > Layout > – there are several areas for changing the site padding from:

    Header
    Content
    Sidebars
    Footer

    #1184642

    sporenborg

    Thank you. This i noticed … but for tablet the padding-left is not working. Desktop padding 0 left is wanted. Pls have a look at /category/studien/

    #1184837

    David Customer Support

    Desktop and Tablet uses the same padding. And as you have zero padding on the desktop settings then it also applies to the tablet.

    Try this, in Customizer > Layout > Container, Add Left Padding to the container for desktop, then select Text for Container Alignment

    #1185254

    sporenborg

    Thx David!

    #1185339

    David Customer Support
    #1213431

    sporenborg

    Hey David,

    one more question to this topic: Left Padding to the container for desktop has no effect to the blog for tablets. Why? I think I tried all options to set the left padding > 0px.

    Thank you

    #1218383

    David Customer Support

    In the Customizer > Layout > Container you can set the Content Padding for desktop and mobile size devices. Just make sure that both contain a value

    #1220488

    sporenborg

    both contain values …

    #1221033

    Leo Customer Support

    Looks like the Contained option is used which is removing the default padding the customizer:
    https://docs.generatepress.com/article/page-builder-container/

    The padding on mobile is actually coming from this CSS:

    @media (max-width: 768px) {
    .contained-content.separate-containers .inside-article, .contained-content.one-container .site-content {
        padding-left: 8%;
        padding-right: 7%;
    }
    }

    If you use the Default option then you shouldn’t need to use the CSS to set the padding.

    #1223105

    sporenborg

    I just disabled the mentioned css … and it doesn’t work … an mobile …

    #1223247

    David Customer Support

    As Leo mentioned you have to change the Page Builder container to Default:

    https://docs.generatepress.com/article/page-builder-container/

    This options may also be enable / disabled in a Layout element:

    https://docs.generatepress.com/article/layout-element-overview/

    #1223280

    sporenborg

    It is … (maybe I should mention it is about the blog area)

    Template: Standard Template
    Page-Builder-Container: Standard

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.