Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Resolved] Generatepress and SSL

Home Forums Support Generatepress and SSL

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #159084
    Stefan

    Hi,

    after installing a SSL certificate I have problems with a “insecure content” warning. I could already solve most of the problems after reading https://wordpress.org/support/topic/gp-premium-and-ssl and https://generatepress.com/forums/topic/images-missing-when-page-uses-ssl/

    But I couldn’t find any possibility in the backend to change the logo of my site into something other than http…
    Is there a way to fix this?

    Best regards.

    #159085
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    You may just have to re-upload your logo to allow WordPress to set it as https instead of http.

    Let me know if that helps or not ๐Ÿ™‚

    #159139
    Stefan

    That was quick ๐Ÿ™‚
    I don’t know what was exactly going wrong, because I tried already some days ago and checked for results every day. I have WP Super Cache installed and cleared the cache several times already. Now I wanted to upload the image again, as you suggested, and noticed that the logo is suddenly delivered by https.
    Seems like it was a cache problem.

    Thank you very much for your help.

    #159196
    Tom
    Lead Developer
    Lead Developer

    Ah, cache can be tricky!

    Glad it’s working ๐Ÿ™‚

    #167332
    Stefan

    Hi,

    I’m not really sure what happened that day when I said that the problem was solved. The next day it wasn’t working any more. I waited some days to be sure it is not a cache-problem. Maybe I didn’t look close enough and there was still an error…

    A month later I decided to look after the problem again. I found a solution for the problem by inserting

    if ( is_ssl() ){
    $generate_settings['logo'] = str_replace( 'http://', 'https://', $generate_settings['logo'] );
    }

    right behind the comment //Site logo in line 555 of the file template-tags.php

    Because I’m not good in php I don’t know if this is a good solution – but it works.

    But I realized that there are other pictures deliveres by http instead of https: the wp-post-image has a tag src where the image is delivered by https – it also has a tag scrset wher the image is delivered by http.

    I searched a while where the code for wp-post-image is generated, but I found nothing. So I have no idea to fix the problem…

    #167439
    Tom
    Lead Developer
    Lead Developer

    If the URLs in “Settings > General” are set to https, WordPress should change all of the post images (wp-post-image) to https automatically.

    This plugin may be worth trying as well: https://wordpress.org/plugins/ssl-insecure-content-fixer/

    #167929
    Stefan

    If the URLs in โ€œSettings > Generalโ€ are set to https, WordPress should change all of the post images (wp-post-image) to https automatically.

    Perfect. That solved the problem ๐Ÿ™‚
    Thank you very much!

    #167971
    Tom
    Lead Developer
    Lead Developer

    You’re very welcome ๐Ÿ™‚

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.