[Support request] GenerateBlocks: Whitespace above header

Home Forums Support GenerateBlocks: Whitespace above header

  • This topic has 3 replies, 2 voices, and was last updated 1 month ago by David.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1415331
    Hashim

    Hi there,

    I just installed GeneratePress Premium today along with GenerateBlocks. I’m completely new to GeneratePress and GenerateBlocks and I’m looking to do things with as little coding as possible.

    I’m trying to create some sort of landing page for a minicourse. Fairly basic with just some copy and a Gravity Forms signup form. No images, just background colors with gradients.

    So because I’m still a newbie I might be doing this the wrong way. But when I created a new page, I chose all the correct settings so that no sidebars are shown and the page is full width. After that I wanted to create a header for that page to show the headline. So I added a container block with a one column grid block in it and a headline block in the one column. I gave the container a background color with a gradient and adjusted the size of the headline.

    Then I noticed two things…

    1. There’s this whitespace above that container I can’t get rid of.

    2. I can’t find a way to get rid of the navigation menu for just that page.

    Can you help me create the landing page I want by getting rid of that whitespace and the navigation menu?

    I’m looking forward to your reply. Thank you in advance!

    Sincerely,

    Hashim

    #1415728
    David
    Staff
    Customer Support

    Hi there,

    1. In the Block Editor – make sure there is NOT an empty Paragraph Block above your content/
    2. You can use the Disable Elements meta box in the editor, to remove Primary Navigation and Mobile Header ( if required ):

    https://docs.generatepress.com/article/disable-elements-overview/

    #1415986
    Hashim

    Hi David,

    Thank you for your reply!

    I had the Disable Elements option not activated yet, that’s why I couldn’t find the option to hide the navigation menu.

    As for the whitespace…

    There was no paragraph before the container block. However I also disabled the header and the featured image/page header with Disable Elements. I’m guessing that did the trick.

    Thank you, David!

    There’s one thing I noticed I wished was possible. And maybe it is and I just can’t find it…

    I can’t find a way to make the height of the container block fill the entire screen. I can only manually enter a height in pixels in the spacing section. And I don’t know what to fill in there so that the entire screen will be filled.

    If that option is missing in the container block, I think that would be a valuable addition.

    Thank you once again, David!

    Sincerely,

    Hashim

    #1416011
    David
    Staff
    Customer Support

    Awesome – glad to hear that 🙂

    If you select a Container Block or any of the Grid item containers. In the Settings > Spacing you will see the Minimum height field. Beside it you can select VH ( viewport height ) Units and enter 100 to fill the height of the screen.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.