[Resolved] Footer Widget not displaying

Home Forums Support Footer Widget not displaying

  • This topic has 14 replies, 3 voices, and was last updated 3 months ago by David.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #1334318
    Brian

    Hi,

    I am trying to add contact info to a site. I wanted to add location and phone and email details in two widgets. My problem is that I can only see one of them on the front end. I only want it to display on certain pages. I tried to add it as a hook but the problem is that I don’t know what the best way to display the content side by side. I tried using generateblocks but it made a mess of it. Would the best way be to use the lightweight grid plugin in hooks instead?

    Kind Regards,

    Brian Thompson

    #1334505
    Leo
    Staff
    Customer Support

    Hi there,

    What is your footer widget number setting in the customizer?
    https://docs.generatepress.com/article/footer-widgets/

    Let me know 🙂

    #1334652
    Brian

    Hi Leo,

    I first tried adding them through the normal way Appearance > Widgets and then going into the customize > layout > footer and setting it to 2 but only one showed up. I have retried it again and I checked the page which is set to the default option but still no joy. However, earlier on I was able to add them in the customiser by widgets > footer widget 1 and footer widget 2 and they seemed to work ok for some reason but it didn’t work the other way. I took them off that and reinstated the old way and now there is nothing showing up despite the layout > footer being set to 2 and the page set to default.

    I also tried setting the widgets to two on the page but now nothing is showing. Could you please show me where I am going wrong?

    Kind Regards,

    Brian Thompson

    #1334715
    Leo
    Staff
    Customer Support

    Is the issue happening on every page?

    If so can you check if there is a layout element setting the footer widget number to 0?
    https://docs.generatepress.com/article/layout-element-overview/#footer

    #1335134
    Brian

    Hi Leo,

    The pages I have checked are all set to default on footer widgets. The layout > Footer > Footer widgets is set to 2 but no footer widgets are showing up on the pages.

    Kind Regards,

    Brian Thompson

    #1335531
    Leo
    Staff
    Customer Support
    #1338395
    Brian

    Hi Leo,

    No. Not that I am aware of. I have disable elements deactivated and I only have two hooks. One is for the analytics script in after_footer_content and the other one is for font awesome in wp_head.

    Kind Regards,

    Brian Thompson

    #1338410
    Brian

    Hi,

    I just tried to make up a new layout element with footer widgets set to two, content area set to default and display rules location set to front page and still no joy.

    Kind Regards,

    Brian Thompson

    #1338655
    David
    Staff
    Customer Support

    Hi there,

    can you make sure that:

    1. You have NO Layout Elements that changes the Footer Widgets #
    2. The pages you want the footers displayed on, are NOT using the Layout Meta Box to change the Footer Widgets #

    https://docs.generatepress.com/article/layout-metabox-overview/

    3. Then in Customizer set the Layout > Footer > Widgets are set to 2.

    Now try adding 1 HTMKL Widget to each widget area. And just add some plain text. E.g ‘contact’

    Once done let us know.

    #1339871
    Brian

    Hi David,

    Thank you for getting back to me. I took away all the layout elements for the footer. I also made sure that the meta box on the footer is set to default. I also went into Layout > Footer > Widgets which I had set to 2. Then I added 1 html widget to each widget area and added plain text and it works! Thank you very much! The only thing is that only want to display them on the home page and not on the rest of the site.

    When I looked at the metabox this morning, I realised that it had been set to two. When i did it originally, i used the text widget, will know better next time.

    Kind Regards,

    Brian Thompson

    #1339973
    David
    Staff
    Customer Support

    Glad to hear that.
    Now you can create a new Layout Element – set the Footer Widgets to 0.
    Then on the Display rules:

    Location: Entire Site
    Exclusion: Front Page

    #1340007
    Brian

    Thats Great. Thanks for that, Much appreciated!

    Also, Just wondering is it possible to have the primary navigation main menu as uppercase and the sub menu as lower case, and also, how do I change the padding of the submenu without it affecting the main menu?

    Kind Regards,

    Brian Thompson

    #1340095
    David
    Staff
    Customer Support

    Add this CSS to unset the text-transform for the sub menus.

    .main-navigation .main-nav ul ul li a {
        text-transform: unset;
    }

    When you say padding – are you trying to make the sub menu items a different height or reduce the space around them? let me know.

    #1340143
    Brian

    Thank you David, Much Appreciated!

    Kind Regards,

    Brian Thompson

    #1340163
    David
    Staff
    Customer Support
Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.