[Support request] Footer Widget

Home Forums Support [Support request] Footer Widget

Home Forums Support Footer Widget

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #604968
    Samantha

    Hi

    I have been given a weblink to a live graph to inlcude on my home page in the footer. However, I am not sure of the code to write in the HTML widget box?

    I literally just have the weblink.

    Here is one of the graphs: http://www.goldchartsrus.com/data/click/clickAUtn.php

    I am trying to put it on my website footer. I have four graphs in total, and you will see the titles where they should appear under here: http://www.blockchainbullion.io

    GeneratePress 2.1.2
    #604980
    Samantha

    I am currently using this code in the footer html widget:

    but it doesn’t show anything

    #604981
    Samantha

    well I didn’t mean for that to happen! so it seems I can’t show you the code…

    is there any reason why the code won’t be working in the footer widget? it works everywhere else

    #605018
    Samantha

    It doesn’t actually show anywhere on my website, its just a blank area. Perhaps I haven’t put the correct coding in

    #605092
    David
    Staff
    Customer Support

    Hi Samantha,

    the link in your site is a HTTPS request. The request failed as there is no valid certificate. Can you check with the provider of those services if they have a valid SSL certificate version.

    #608635
    Samantha

    Hi David

    Does this mean the graph will not show on my website because they are http: rather than https: ?

    I still can’t seem to get the graph to show in my footer.

    At the moment I have graphs from goldcharts as it is a plugin.

    However, somebody has created custom graphs for me to use and has provided me with a http web link which shows the graph.

    I am trying to put the graph in each of the footer areas.

    What is the correct coding to show this live graph from a weblink?

    #608675
    David
    Staff
    Customer Support

    Hi Samantha, try switching out those broken links with the HTTP equivalent e.g

    <a href="http://www.goldchartsrus.com/data/click/clickAUtn.php" target="_blank" rel="nofollow"><img src="http://www.goldchartsrus.com/data/click/clickAUtn.php" alt=""> </a>
    <script src=”http://www.goldchartsrus.com/data/click/clickAUtn.php” async></script>

    Once done we can test for mixed content concerns.

    #608694
    Samantha

    Hi David

    I have removed everything from each of the footer areas, and then I have placed a HTML box in each footer area 1-4. Then I used your code with the http web links.

    They are still not showing.

    #608698
    David
    Staff
    Customer Support

    Hi Samantha, edited the code above can you try that.

    #608830
    Samantha

    Hi David, I have tried the code and cleared my cache but it still isn’t showing.

    #608836
    David
    Staff
    Customer Support

    Hi Samantha, the links in the footer widgets are still displaying as HTTPS, hence they are not working. Are you using any SSL plugin that is forcing all links to HTTPS?

    Ideally, could the provider of those links server them over HTTPS?

    #608837
    Samantha

    Hi David, that must be what it is! I have a plugin called: Really Simple SSL installed.

    This is what the configuration currently is showing as:

    (tick) SSL is enabled on your site.
    (tick) Mixed content fixer was successfully detected on the front-end
    (tick) An SSL certificate was detected on your site.
    (tick) 301 redirect to https set: WordPress redirect
    (warning) HTTP Strict Transport Security is not enabled. To enable, get Premium
    (warning) Secure cookie settings not enabled. To enable, get Premium

    This is what the settings currently are:

    (tick) Auto replace mixed content
    (tick) Enable WordPress 301 redirection to SSL
    (not ticked) Enable 301 .htaccess redirect Before you enable this, make sure you know how to regain access to your site in case of a redirect loop.
    (tick) Enable Javascript redirection to SSL
    (not ticked) Debug
    (not ticked) Stop editing the .htaccess file
    (not ticked) Switch mixed content fixer hook

    #608838
    Samantha

    I would have sent a screenshot, but I am not sure how to upload the image to here! So I hope that my writing above makes sense 🙂

    #608844
    David
    Staff
    Customer Support

    Try unchecking the ‘Auto replace mixed content’ and ‘Enable Javascript redirection to SSL’. Then lets see what happens. 🙂

    For future ref, to add an image you need the image to be hosted somewhere and then you can add it using the img button in this editor

    #608859
    Samantha

    Thanks so much it has worked! I will now update my other footer widgets with the code you sent me! Thanks so much! It had been such a huge pain for a while! finally I can see the graphs!! 🙂

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.