[Support request] Footer text doesn’t update

Home Forums Support [Support request] Footer text doesn’t update

Home Forums Support Footer text doesn’t update

  • This topic has 15 replies, 5 voices, and was last updated 2 weeks ago by David.
Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #2300395
    Dani

    This is a very odd bug that I’m experiencing. In the Customize > Layout > Footer, I’ve set a custom text and it successfully saves it.

    However, when you refresh the page, it’s the old text.

    I’ve tried different browsers, removed the cache, but nothing works.

    What can I do to fix this?

    #2300399
    Fernando
    Customer Support

    Hi Dani,

    To have a better understanding of the issue, may you kindly provide the link to the site in question?

    You may use the private information field for this: https://docs.generatepress.com/article/using-the-premium-support-forum/#private-information

    Hope to hear from you soon.

    #2300537
    Dani

    I’ve updated the info, you should see it now.

    #2300998
    Ying
    Staff
    Customer Support

    Hi Dani,

    What’s the new text?

    Is it © 2022 your site domain?

    Let me know!

    #2301010
    Dani

    No, that’s the text that I cannot change for whatever reason despite how many times I try. I’ll add the new text in the private information section

    #2301049
    Leo
    Staff
    Customer Support

    Do you see the text change when you edit it in the customizer?

    #2301482
    Dani

    Yes, I do. I see it in the preview, hit the publish button, still see it in the preview, then actually go to home page and it’s the old text. Where’s the problem? Why it’s not updating it properly?

    #2301489
    Fernando
    Customer Support

    Hi Dani,

    Can you double check if this is set to publish when you make edits?: https://share.getcloudapp.com/kpu82D55

    If it is, can you check with your hosting provider if you have server side cache? I can also see that you use CDN Cloudflare. Try clearing your CDN cache if there is one set as well.

    #2301518
    Dani

    After 35 min of a live chat with my hosting company, we established that the problem was the emoji that I used.

    To quote what they said “It is not recognizing it and I think you may need a special code/script to include that symbol in your footer.”

    Is there a way to include an emoji in the footer?

    #2301546
    Fernando
    Customer Support

    I see. This shouldn’t be a GP issue though. I tested the emoji from my end and it’s working as expected.

    Can you check if one of your plugins is disallowing it?

    Maybe you can try #1 here?: https://docs.generatepress.com/article/debugging-tips/

    #2301845
    Dani

    I disabled all of the plugins but GP. It doesn’t work. It’s not adding the emoji but sticks to the old text.

    #2301908
    David
    Staff
    Customer Support

    Hi there.

    i assume the emojis are disabled on your install, you could try adding the HTML to load it.
    Edit your Copyright text in the footer, and where you want the tomatoe, add this:

    <img draggable="false" role="img" class="emoji" src="https://s.w.org/images/core/emoji/14.0.0/svg/1f345.svg">

    #2301911
    Dani

    Bless you, that actually works. However, how do I enable emojis? Isn’t that something enabled by default in WP? Or is it a hosting thing?

    #2301921
    David
    Staff
    Customer Support

    Ok, i just checked your site, and Emojis are enabled.
    I think it may have simply been the pretty emoji you added isn’t included in the WP frontend emojis. What i can’t explain is why on your install it did not covert it to the flattened emoji. That could be wp-config thing on your server, but i am unsure there.

    #2301936
    Dani

    I understand. This is solved, for now, if it happens again, I’d know that it’s the emojis.

    Many thanks, everyone!

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.