[Resolved] Featured image not displaying in blog page header

Home Forums Support Featured image not displaying in blog page header

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #557105
    Caroline

    I’ve done a search but I can’t see any other posts featuring exactly the same issue.

    I’m having an issue with the featured image not showing on my newly created blog post page header. I’m trying to use the same page header I’ve used successfully on most of my other pages. I set it up by going into ‘Global Locations’, and allocating the page header to “Posts page (blog)”. I’ve then set the featured image on the blog page. However, the image isn’t displaying (the page title isn’t either). Any ideas?

    I’ve included the URL for the blog page in the field below. You can see what the header’s supposed to look like by navigating through the website menu and looking at the other pages.

    Individual blog post headers are displaying fine.

    Thanks for your help!

    GeneratePress 2.0.2
    GP Premium 1.6.2
    #557283
    Leo
    Staff
    Customer Support

    Hi there,

    Where did you add the featured image of the blog page?

    WordPress ignores metabox on index pages (blog and archive) so make sure you create a page header specific for the blog page and upload the image through page header: https://docs.generatepress.com/article/page-header-image/

    Let me know if this helps.

    #557306
    Caroline

    Hi Leo

    OK, I had previously set the featured image on the blog posts page, as that’s what i’d done for all the other pages.

    I’ve tried your suggestion, however, and it’s still not working. Here’s what I’ve done:

    • Created a new page header: “Blog page header”;
    • Set the featured image inside this header to the image I want to use;
    • Gone back to the blog page and removed the featured image;
    • Gone to ‘Global locations’ and set the Posts Page (blog) to “Blog page header”
    • Removed any reference to a page header in the “Page header” box at the bottom of the blog page.

    However, it’s still not working – in fact the header has disappeared completely. Any other ideas?

    Thanks!
    Caroline

    #557588
    Leo
    Staff
    Customer Support

    Did you turn on add background images?

    If so can you turn off autopimize and any caching plugin for now?

    Let me know.

    #558050
    Caroline

    Hi Leo

    I figured it out – I hadn’t added any padding so it wasn’t displaying!

    Just one other thing though – I seem to be unable to pull in the page title using {{post_title}} in the content area (another reason it wasn’t displaying – as well as having no padding there was no content), so I’ve had to type it in manually. Is this just the way it is?

    Thanks again.
    Caroline

    #558143
    Leo
    Staff
    Customer Support

    Yeah for the blog page there isn’t a title added by default so you would have to manually added it in.

    It should work for static pages though 🙂

    #558209
    Caroline

    Yes, it works fine on the other pages. Thank you!
    Caroline

    #558247
    Leo
    Staff
    Customer Support
    #784768
    Anna

    Hello, I have the same problem as Caroline, but nothing works for me. I’ve done all steps from post #557306 but all I can see is the title. Can you help me?

    site adress: http://annadyl.stronazen.pl/blog/

    #784772
    David
    Staff
    Customer Support

    Hi there,

    for the blog page you need to assign a Background Image > Custom Image.

    #785282
    Anna

    Yes, I did this and it doesn’t work 🙂

    #785394
    David
    Staff
    Customer Support

    HI there,

    can you clear your browser cache ( or open in an incognito / private browser ) as i can see an image in the Blog header. let me know

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.