[Support request] Featured image in webp format

Home Forums Support Featured image in webp format

  • This topic has 11 replies, 3 voices, and was last updated 3 months ago by David.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1348469
    Dalibor

    If I load the .webp image in the media library and use it as a featured image, it does not scale down on mobile. It loads a full-size version only.
    What would be the best way to approach this?
    Is there a way so that .webp images are also auto-scaled down (like regular jpeg) for the better mobile experience?

    #1348760
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Not super familiar with .webp images, yet, but I don’t see why they wouldn’t scale. Is there a specific page where we can see the issue?

    #1349105
    Dalibor

    Sure, take a look here: https://freelancerin.com/, I’ve returned it here only for your testing. Please let me know when you are done.

    #1349264
    David
    Staff
    Customer Support

    Hi there,

    i am not seeing any srcset images in the featured image markup.
    Can you try disabling plugins such as lazy loader?

    #1349303
    Dalibor

    Lazy load through Autoptimize disabled.

    #1349328
    David
    Staff
    Customer Support

    Well, its not the lazy loader.

    Do you have any other plugins or functions related to Images?

    #1349351
    Dalibor

    Autoptimze, Wp fastest cache, Asset cleanup, Async javascript, Heartbeat control, Clearfy, WP optimize… take your pick ;).
    I’ll turn them all off now.

    All plugins offline.

    #1349354
    David
    Staff
    Customer Support

    Can you:

    1, Check the settings in Customizer > Layout > Blog –> Featured Images Posts.
    Make sure the Attachment size is Full, and the Width and Height fields are empty.

    2. Now upload a JPEG image so i can see if that is working correctly.

    #1349365
    Dalibor

    It is already set up like that. And as I have stated before, JPEG images are working correctly.
    My guess is as I needed to install the plugin (WP Enable WebP-https://wordpress.org/plugins/wp-enable-webp/) to upload WEBP files to the media library, it somehow regulates CSS setup for WEBP featured images?

    Edit: plugins back on

    #1349435
    David
    Staff
    Customer Support

    Sorry i assumed you must of been using a plugin or script to allow support for webP images as WP doesn’t support them by default.

    And i am not sure that plugin will fix the problem either, as it comes down to WP supporting WebP when it creates the various media attachment sizes. You may need to look at some of server side / CDN options – like this plugin requires:

    https://wordpress.org/plugins/webp-express/

    Hopefully WP will start supporting it natively in the near future

    #1349762
    Dalibor

    This plugin has resolved the issue, thank you.

    #1349778
    David
    Staff
    Customer Support
Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.