[Support request] Fatal Error Using UpdraftPlus with GP-Premium plugin

Home Forums Support Fatal Error Using UpdraftPlus with GP-Premium plugin

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1046969
    Jim

    Hi,

    I received a “Fatal Error” using the UpdraftPlus plugin with GP-Premium. I bought GP-Premium a few days ago, so I’m using the latest version. I’ve always had good luck with Updraft and want to continue using it.

    Thoughts/Recommendations?

    Jim

    #1047002
    Leo
    Staff
    Customer Support

    Hi there,

    I don’t believe GP Premium should cause incompatibilities like this.

    Does it occur if GP Premium is the only activated plugin?

    If so what happens if you disable GP Premium?

    #1047127
    Jim

    Thanks for the fast reply:

    I used both plugins for a few days without a problem. I called Siteground and they were able to fix the problem by disabling Updraft and I was told it was a compatibility issue with the GP plugin.

    I’m away from desktop and haven’t tried disabling any other plugin, since SG said it was Updraft. I want to use GP premium.

    #1047132
    Leo
    Staff
    Customer Support

    GP premium really shouldn’t cause any issues like that.

    Can you do the debugging test first and report back?

    #1047276
    Jim

    I received this email from WP today:

    Howdy!

    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

    In this case, WordPress caught an error with one of your plugins, GP Premium.

    First, visit your website (https://touringtx.com/) and check for any visible issues. Next, visit the page where the error was caught (https://touringtx.com/wp-admin/) and check for any visible issues.

    Please contact your host for assistance with investigating this issue further.

    If your site appears broken and you can’t access your dashboard normally, WordPress now has a special “recovery mode”. This lets you safely login to your dashboard and investigate further.

    https://touringtx.com/wp-login.php?action=enter_recovery_mode&rm_token=wfkyqvfZpDaKgcxWKt653N&rm_key=gjeU48hsKnLiPKWS4grJQ7

    To keep your site safe, this link will expire in 1 day. Don’t worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

    Error Details
    =============
    An error of type E_ERROR was caused in line 166 of the file /home/privat80/public_html/touringtx.com/wp-content/plugins/gp-premium/gp-premium.php. Error message: Allowed memory size of 805306368 bytes exhausted (tried to allocate 20480 bytes)

    #1047292
    Leo
    Staff
    Customer Support
    #1047298
    Jim

    Siteground raised memory to their max 768M and I still received Fatal Error with Updraftplus active. The tech disabled that plugin and the site works fine. For some reason, GP seems incompatible with Updraftplus on my site. Suggestions?

    #1047313
    Tom
    Lead Developer
    Lead Developer

    Something must be spiking the memory limit. I just installed UpDraftPlus and I’m not noticing any issues on my end of things.

    I wonder if it’s another plugin causing the spike? It’s possible that disabling UpDraftPlus is “fixing” the issue by bringing you under the limit, while something else is actually using more memory.

    #1047320
    Jim

    I switched backup plugins and hopefully, this one won’t have an issue. SG raised the memory to 768M and I saw 128M on your instructions, so that seems to be an awfully big cushion, it doesn’t seem possible, as a layman, that it would spike that high. I did install two Zoho plugins just before, so maybe they are the issue, although I have used both on several sites with different themes, successfully.

    Jim

    #1047966
    Tom
    Lead Developer
    Lead Developer

    Definitely something strange going on – I wonder if the limit only says it’s that high.

    Hopefully the new backup plugin fixes the issue 🙂

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.