Premium support

Please log in to post in these forums. If you didn't create an account when you purchased, please contact us.

Free support

If you haven't purchased GP Premium, support for the free theme can be found on WordPress.org.

[Resolved] Failed to update to 1.5

Home Forums Support Failed to update to 1.5

This topic contains 11 replies, has 4 voices, and was last updated by  Tom 1 week ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #418990

    Hi Wizzards,

    I wanted to update to 1.5 and then I got an “Unauthorized” message because indeed the URL has changed since the license key was activated. So as per instructions I deactivated the key and activated it again. And then when I wanted to upgrade the plugin

    — BOOM

    I cannot acces my site anymore.

    I get a big connection error screen:

    This site can’t be reached
    landcruisingadventure.com refused to connect.

    Questions:

    – How can this happen?
    – What can I do to solve it?
    – How can I prevent it from happening again?

    —C

    GeneratePress 1.4
    #418991

    Tom
    Lead Developer

    Hi there,

    So this happened once you initiated the update again, once you had re-saved your license key?

    I was able to access your site – is it only the backend that’s down?

    #418996

    Hi Tom,

    I just went in via FTP and deactivated the GP-Premium.

    So I can go in as well… just now..

    What is my following action?

    #418997

    Tom
    Lead Developer

    What happens when you re-activate GP Premium?

    #418999

    Okay… Just went ahead an activated the plugin again and updated successfully to 1.5

    Pfew…

    I don’t like these kind of things! 🙁
    —C

    #419002

    Tom
    Lead Developer

    Very strange, hopefully just a random one off thing.

    Let me know if you run into any other issues 🙂

    #419013

    Will do. Great work!

    #421110

    I am sorry to have to ask for help updating from GP Premium 1.4.3 to the latest version.
    (How is everyone else able to make this work? What am I missing? How can I have survived this long if I am that much less capable then everyone else?)
    &
    All attempts at updating produce the error message: “Briefly unavailable for scheduled maintenance. Check back in a minute.”
    The site is unavailable until I delete “.maintance” from the root directory.
    &
    On my plugins page, under GP Premium, the update link is
    http://localhost/gp3/wp-admin/update.php?action=upgrade-plugin&plugin=gp-premium%2Fgp-premium.php&_wpnonce=afb45919dc
    &
    I am running the site under localhost, Windows 7 64 bit Premium Service Pack 1, MySQL 5.7, Apache 2.4, WordPress 4.8.3
    &
    Below are details:
    I tried to update from version 1.4.3 to newest version. The error message: “Briefly unavailable for scheduled maintenance. Check back in a minute.”
    I signed out of my site
    I remove “.maintance” from the site’s root directory.
    I logged on to my site.
    I tried again to update from version 1.4.3 to newest version. The same error message appeared.
    So I again Logged off > removed “.maintance” > Logged on.
    On the 3rd try the GP Premium plugin again did not update. The error message, under “GP Premium” on the plugin page, was: “Update Failed: Connection lost or the server is busy. Please try again later.”
    I logged out > logged in > “Briefly unavailable…” > Logged out > removed “.maintance” > Logged in.
    I read November 8, 2017 at 4:57 pm #418990, Coen: (deactivate and then reactivate).
    So this time I tried deactivating GP Premium 1.4.3 and then activating it.
    Attempted to up date > Failed again “Update Failed: Connection lost or the server is busy. Please try again later.”
    I would greatly appreciate help.
    NOTE: Does WordPress think it is cute to display the mocking error message “Briefly unavailable…” when in the real world the site will never be available until repaired?

    #421192

    Tom
    Lead Developer

    Interesting, it could be because you’re running WordPress on Windows 7. Perhaps the plugin mentioned here will help?: https://docs.generatepress.com/article/updating-issues/#could-not-copy-file

    #421244

    John,
    Another idea, since you don’t mention that point:
    Did you flush your browser cache, or, if so but without effect, any plugin cache in use?

    #421586

    I am grateful for the suggestions. Thanks for telling me about the Windows Compatibility Fix plugin. Thanks for the reminder about flushing the browser cache. I did flush the browser cache.
    I used pale moon 25.7.1 for the first tries. I next tried FireFox 56.0 and had the same failure. (I use Linux Mint 18.2 (Ubuntu 16.04) usually. My wife wants me to build a site she can pretty much manage on her own, under Windows 10.)
    &
    What worked for me was to uninstall GP Premium 1.4.1, log out of the WordPress site, log back into the WordPress site, THEN install GP Premium 1.5.1 as a new plugin, AND go back to the all plugins page to activate GP Premium 1.5.1.
    &
    Details:
    To update GP Premium from 1.4.1 to 1.5.1
    Deactivate, then delete GP Premium 1.4.1.
    Log out of WordPress site.
    Log in to WordPress site.
    Install GP Premium as a new plugin, but do NOT activate from the new plugin page.
    Go to all plugins page.
    Activate GP Press 1.5.1 from all plugins page.
    NOTE:
    I tried deleting GP Premium 1.4.1, and then installing new plugin GP Premium 1.5.1, without logging out. But when I did that the all plugin page showed GP Premium was version 1.4.1 and had a message to “update to GP Premium 1.5.1.” Something was wrong, but I had wasted too much time getting the update to work so I just did as described under “Details” and did not investigate further.
    &
    I have the Elementor Pro 1.9.5 plugin installed. Elementor has previously caused problems and I would have next tried uninstalling Elementor and Elementor Pro then doing the GP Premium 1.5.1 update. But when I got to something that worked, I stopped.

    #421802

    Tom
    Lead Developer

    Very strange – thanks for posting what worked for you. Looks like you just had to manually update – possibly due to being on Windows 7.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.