[Support request] Embed pdf without plugin

Home Forums Support Embed pdf without plugin

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #954778
    Linda

    Hi Support,

    I’m trying to embed a PDF file in a site page without having to add yet another plugin.

    I found this article:
    How to Embed and View PDF without Plugin

    Using it, I copied this code and inserted it as HTML:
    <embed src="https://new.mygoforthegreen.com/wp-content/uploads/2019/07/5-Simple-Tips-That-Close-Deals.pdf" type="application/pdf" width="774" height="774"></embed>

    Tried it with Classic editor block as well as Custom HTML block, but get only a blank area, no PDF.

    Questions:
    Do you know how I can make it work without a plugin?
    Or do I have to add a plugin to do this in GeneratePress?
    If I have to use a plugin, would you recommend one that works well with your theme?

    Thanks for your help!

    Linda

    #954790
    David
    Staff
    Customer Support

    Hi there,

    have you checked the frontend of the site to see if it displays? It may not ( probably won’t ) display in the editor.

    #954798
    Linda

    Hi David,

    Great idea. I’ll check to be sure … unfortunately, even after I publish the page, I see only page title.
    Test Page

    Linda

    #954800
    David
    Staff
    Customer Support

    It looks like its working for me – open the page in an incognito / private browser to see if its a browser caching issue. Also check to make sure you have no browser extensions that may be blocking it.

    #954813
    Linda

    Hi David,

    Huh, that’s odd but good news.

    I tried Private browsing and cleared my Firefox cache – no luck. I tried Chrome and it’s there.

    So do I check Firefox extensions and compare them to Chrome ones to see which ones are different? Or would you suggest just working through Firefox extensions and disabling one by one?

    Thanks so much for checking it out at your end. I had not thought to check another browser because it’s HTML and I figured I’d done something wrong, not being HTML adept!

    Linda

    #954823
    David
    Staff
    Customer Support

    i have a vanilla dev install of FF and its working there too. So yes must be an extension blocking it – i would start with any adblocker extensions as they are the likely culprit.

    #954825
    Linda

    Okay, sounds like a plan, David. Thanks. 🙂

    I’ll post back the results in case anyone else is seeking a similar solution!

    Linda

    P.S. I’m not just “happy” with GP support … I’m delighted with it!!

    #954828
    David
    Staff
    Customer Support

    You’re welcome.
    Thanks for the feedback 🙂

    #954835
    Linda

    Update: no luck. I have no adblocker extensions and disabled ones I have one-by-one, but nothing works. Disabled them all for Private Browsing, cleared that cache and tried there: same result. No Firefox-unique plugins are causing the issue, either, since I tried disabling each of the 2 there are, with same result.

    Realize this is not a GP issue, so will see what I can find out. Regardless, will post my results … once I have some! 😉

    Linda

    #954837
    David
    Staff
    Customer Support

    Thats odd – if you can inspect the page in the FF dev tools – maybe an error or warning in the console that could shed some light on it.

    Alternative try:
    https://en-gb.wordpress.org/plugins/pdf-embedder/

    Not sure what embed method they are using and whether it will work in your FF – but it does include an Embed Block.

    #954870
    Linda

    That’s a good idea, David. I’ll see if I can do that to get some more insight.

    I know that plugin is an option, but hope to avoid another plugin. They seem to mount up in WordPress and I worry about site speed. I believe you’ve told me before plugins that accomplish just one task don’t affect speed that much, but i worry.

    AHA! Decided to try this on my partner’s laptop … it opened perfectly in Firefox! So the problem is with my computer. That means I will just not worry about it, do any checking in Chrome and sleep much better at night!!

    I have to get my process working better: check in both computers before spending hours trying to fix something that “ain’t broke”. Think I’ll put a sign up right beside my keyboard.

    As always, David, I really appreciate your patience working me through issues that shouldn’t even be issues. I promise to try harder as above before coming to you next time!

    Linda

    #954877
    David
    Staff
    Customer Support

    Not a problem – glad to be of help.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.