[Support request] Elements – Featured and fallback image not shown on translated page

Home Forums Support [Support request] Elements – Featured and fallback image not shown on translated page

Home Forums Support Elements – Featured and fallback image not shown on translated page

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #878823
    Mathias

    I am working on a big client project. Today I installed WMPL and started to translate the website. I also translated the header element I use for the front page and another one for the static pages.

    I recently noticed that the featured and fallback image that I used in the elements is not shown on the translated pages.

    Here is the CSS code:

    German page:

    .page-hero {
        background-color: rgba(255,255,255,0.6);
        background-image: url(https://preview.dreiling-maschinenbau.com/wp-content/uploads/2009/07/vollautomatische-montagevorrichtung-kurbelwellengehaeuse.jpg);
        background-size: cover;
        background-image: linear-gradient(0deg, rgba(255,255,255,0.6),rgba(255,255,255,0.6)), url(https://preview.dreiling-maschinenbau.com/wp-content/uploads/2009/07/vollautomatische-montagevorrichtung-kurbelwellengehaeuse.jpg);
        background-repeat: no-repeat;
        color: #35657c;
        text-align: center;
        box-sizing: border-box;
    }

    Translated english page:

    .page-hero {
        background-color: rgba(255,255,255,0.6);
        color: #35657c;
        text-align: center;
        box-sizing: border-box;
    }

    It seems like the original background is not set on the translated element. Maybe this is a bug?

    GeneratePress 2.2.2
    GP Premium 1.8.1
    #879270
    Tom
    Lead Developer
    Lead Developer

    Thanks for reporting this – I’ll do some testing and will get back to you ASAP.

    #879700
    Tom
    Lead Developer
    Lead Developer

    Just testing this. Elements use the featured image where possible. When you create your Element in another language, be sure to check this box before you hit publish: http://prntscr.com/ngyi90

    If you do that, the image should come along with the rest of the settings.

    Let me know ๐Ÿ™‚

    #880308
    Mathias

    Hi Tom,

    your hint was right: I had to check this box and after that the featured image was shown.

    But I also have some pages with a fallback image in my element. The fallback image is not shown on the page of the other language. I think it would be important that the fallback image is used for all languages as some editors will have pages without a featured image. If this image is part of the frontend design there will be a ugly white space.

    Can you fix this in GP Premium 1.8.2?

    #880646
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    The “fallback” image defined inside the Hero settings? If so, that just sets the featured image of the Element, so it should get copied to your language.

    Does the image display in the settings of your other language, but not on the frontend?

    Let me know ๐Ÿ™‚

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.