[Resolved] Elementor problem: "Sorry, the content area was not found in your page."

Home Forums Support Elementor problem: "Sorry, the content area was not found in your page."

This topic contains 12 replies, has 6 voices, and was last updated by  Ray 8 months, 3 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #237213

    Arturo Garcia

    Hi Tom,

    As you know I am a big fan of GeneratePress and since I discovered Elementor I am the happiest man in the world. They work great together.

    But I am having a problem. If I use Elementor in one page it works fine, except if the page is settled as the Home Page, in this case when I try to load Elementor the plugin shows this message:

    “Sorry, the content area was not found in your page. You must call ‘the_content’ function in the current template, in order for Elementor to work on this page.”

    And they suggest to visit this page: https://docs.elementor.com/article/56-content-area-not-found

    I have tried Elementor in three different websites, included arturogarcia.com and the result is always the same, I can edit any page, except the front page.

    Can you help me with that?

    #237356

    Lyle

    Hi Arturo,

    I am using GP and Elementor with no issues on a few sites and numerous test sites and all have their home page created with Elementor.

    For troubleshooting if it’s GP related, have you tried with the WP Twenty Sixteen theme?

    After taking a look at the page source of the site you mention, I see a number of plugins are loaded, including the Thrive Visual Editor. I know that if you are placing a plugin’s shortcode on an Elementor page that doesn’t play well with it, this error can occur.

    Try deactivating ALL plugins EXCEPT Elementor to see if the error occurs. If not, reactivate one at a time, testing each time.

    Cheers!
    Lyle

    http://snifflevalve.com
    Tutorials and tips for GeneratePress, WP Show Posts, WordPress and Elementor

    #237366

    Tom Lead Developer

    Is the front page your posts page (blog)? That might explain it.

    Not sure if it’s a GP problem as much as they can’t edit the content of the posts page as the content is dynamically generated and not added using a static page.

    Let me know 🙂

    #238271

    Arturo Garcia

    Thank you Lyle and Tom,

    Tom, I have used Elementor with static pages (not blog) as front page.

    Lyle, I have tried to deactivate all the plugins except Elementor with the same result, but I have discarded that the problem is with GeneratePress because it has happened when I have activated the twenty sixteen theme too.

    Also I have tried in a new installation of WordPress with only GeneratePress and Elementor and it worked fine in all the pages.

    I´ll investigate more and I will report you if I find the origin of the problem.

    Thank you both for your help.

    #238396

    Tom Lead Developer

    No problem! Hopefully you find the solution 🙂

    #243146

    Arturo Garcia

    Hi guys,

    I already know what happened. When I got this error message was always in the home page, but the problem was not related to the home page, but I had the same plugin´s shortcode running in those pages.

    The plugin that causes the problem is this: https://codecanyon.net/item/the-grid-responsive-wordpress-grid-plugin/13306812

    You have to put a shortcode to show the posts, so if you are working with elementor already open in this page and you activate the plugin, Elementor keeps working, but if you activate the Grid and then try to load Elementor the error message appears again.

    So Lyle was right, it was a problem with a certain plugin and its shortcodes. I have tried to insert contact forms from Contact Form 7 with its shortcode and then load Elementor and it worked fine, so it is not a problem with all the shortcodes, but if you are using shortcodes in a page made with Elementor it worth check it.

    What put me in the wrong way thinking it was a compatibility problem with GeneratePress was the error message. Also I should say that in my first tests I got the error message even with all the plugins deactivated, but later I have ascertained that it was because I was using a cache plugin that kept causing the problem.

    With no cache and no shortcode Elementor has worked perfectly with GeneratePress in all the pages I made since then. I wanted to tell you just in case other GeneratePress users have the same problem.

    Regards!

    #243147

    Lyle

    Hi Arturo,

    Good to hear that you got things sorted.

    As for showing posts in a grid, perhaps take a look at Tom’s amazing WP Show Posts plugin 🙂

    https://wpshowposts.com/

    I can attest that it works very well with Elementor. Just add the WP Show Posts widget which will be in the Elementor panel at the very bottom. Select the WPSP list that you will have created and there are your posts (or pages too if you like).

    And just as a reminder, when adding shortcodes to an Elementor page, make sure to add them to the Elementor Shortcode widget 🙂

    Cheers!
    Lyle

    http://snifflevalve.com
    Tutorials and tips for GeneratePress, WP Show Posts, WordPress and Elementor

    #243151

    Arturo Garcia

    Yes Lyle,

    You are right, I have to try Tom´s plugin, thanks for the advice!

    #243152

    Tom Lead Developer

    Thanks, Arturo!

    Hope you’re having a great week 🙂

    #243903

    Jessica

    I’m having a similar issue except not with Elementor. A different gallery plugin I’m using is suddenly showing me errors. When I disable it, it’s okay.

    I changed themes and the problem persisted.

    Was there an update recently that affected using shortcodes? (that’s the error I am getting + something involving page header in the GP theme). Something isn’t jiving that was working yesterday. Anything that is a common thread here compared to what has already been shared? Literally just comes down to this one gallery plugin and inserting the shortcode. Scratching my head.

    #419132

    jvargasvig

    Dear, I am with the problem, a day ago it happened to me, I left it to solve it the next day and it turns out that I did not have the problem, a few hours later, again the problem occurred, I tried to delete the last plugins that I installed , and nothing. I have not used shortcode on any page.
    I deleted the ultimate shortcode plugin and nothing.
    I do not know what else to do.
    Web: jvargasvig.com

    #419147

    Tom Lead Developer

    Have you contacted Elementor support yet? They’ll likely have a better idea of what’s going on.

    #529943

    Ray

    Below is Elementor’s solution. My issue is with the ‘Shop’ page of Woocommerce. Is there a newer workaround? Will this fix break my page or experience other issues adding this code?


    The common reasons for the_content function not to be called

    There are 3 common occurrences that may be the cause why the_content will not be called:

    – Sometimes the theme has a front page template that is already pre-built and does not include content from the page. This is most common on free WordPress themes.
    – Custom made page templates that do not include the_content.
    – WooCommerce product pages and WooCommerce shop pages that do not include the_content.

    Manual solution

    * Note – Switching to a different theme usually solves this issue. Try switching to a theme like Twenty Seventeen or GeneratePress and see if your problem is solved.

    Add the_content function into the page template’s code.

    This is the line you need to add: <?php the_content(); ?>

    If you are not familiar with where to place this code or how to add it to the page, please contact your website developer so it can be implemented properly as we cannot provide full support for that. Please note that adding this code won’t enable the editing of Archive pages and Latest Post pages.

    If switching to a different theme does not help, please read the following.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.