[Resolved] Elementor Pro, Single Post Theme with Featured Image, Disable Elements not work

Home Forums Support Elementor Pro, Single Post Theme with Featured Image, Disable Elements not work

  • This topic has 5 replies, 2 voices, and was last updated 1 year ago by David.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1002534
    Gian Jones

    I have the latest version of GP Theme: 2.3.2, GP Premium: 1.8.3, and Elementor Pro: 2.6.5. I have all my posts, created with Gutenberg Blocks, all with featured images. These posts when displayed (in search results or as layout cards – Elementor Pro ‘Posts’ element) will always display the featured image, which is exactly how I want them.

    Now when I view a single post, if the ‘Disable Elements – Featured Image / Page Header’ is checked, then that featured image is not displayed (when viewing single posts), which is fine and it works.

    Now, I have decided to use the ‘Elementor Pro – Single Post Theme’ which has the ‘Featured Image’ element. But it doesn’t honour the ‘Disable Elements – Featured Image / Page Header’ if it is checked for that post when using that theme? Is this a bug or have I missed something? I really need to use this Elementor Pro theme for Single posts and was wondering if there is a way around this? I am a web developer and any technical answer is fine by me too. I cannot show the website URL at the moment, as it is in maintenance mode, but hopefully, from my description above, you have an understanding of my web setup.
    If you do require access please contact me privately.

    #1002658
    David
    Staff
    Customer Support

    Hi there,

    by using the Elementor Theme Builder you are replacing the GP Theme templates with those you create. Which means you don’t have the Hooks and Filters that GP uses to do things such as Disable Elements.

    You can simply remove the Featured Image widget from the Single Post template you’re creating in Elementor.

    #1002704
    Gian Jones

    Thanks for your quick response.

    I don’t want to remove the Featured Image widget from the Single Post template. Isn’t there a way that I can use some PHP condition, so that if ‘Disable Elements – Featured Image / Page Header’ is checked, then the Featured Image is not displayed?

    Or are you implying that by using the Single Post template in Elementor Pro, with the Featured Image widget, means that the Disable Elements functionality no longer works?

    Any workaround on this would be much appreciated.

    #1002705
    David
    Staff
    Customer Support

    Sorry little confused. Just to be clear when viewing a Single Post you do not want to see the Featured Image – Is that correct?

    #1002707
    Gian Jones

    I have all my posts, created with Gutenberg Blocks, all with featured images.

    Some (40%) of these posts have ‘Disable Elements – Featured Image / Page Header’ checked.

    So when viewing Single posts using the Single Post template in Elementor Pro, some posts (40% of them) should not show the featured image. This is what I want.

    Is it possible?

    #1002732
    David
    Staff
    Customer Support

    If you must use the Elementor theme templates, then you would need to create 2 x Single Post templates, one with and one without the featured image. And apply the relevant Elementor conditions for each, presumably a Taxonomy. Unfortunately Elementor doesn’t provide page level control to my knowledge.

    The only other way is to code some conditional logic to remove the element, but this is out of our scope, or use the dynamic conditions plugin.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.