[Support request] Elementor not loading in GeneratePress 1.7.2

Home Forums Support [Support request] Elementor not loading in GeneratePress 1.7.2

Home Forums Support Elementor not loading in GeneratePress 1.7.2

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #655289
    Hannah

    I have been using Elementor with GeneratePress Premium and it was working fine until I upgraded to version 1.7.2. Now when I try to edit with Elementor it gets stuck on the load page.

    Elementor works fine when I deactivate the Premium plugin so this is definitely the cause of the problem.

    This is the error message I am getting from Elementor in my System Info:

    ReferenceError: Swiper is not defined
    at http://sienna-blog.local/wp-content/plugins/elementor-pro/assets/js/frontend.min.js?ver=2.1.4 – 2:12065
    2018-08-21 08:11 +00:00
    x 3 times

    ReferenceError: Can’t find variable: Swiper
    at http://sienna-blog.local/wp-content/plugins/elementor-pro/assets/js/frontend.min.js?ver=2.1.4 – 2:12071
    2018-08-21 07:52 +00:00

    I am building my site on a local server so I don’t think there is a way to share it? I am new to web design so I’m unsure what information to provide in order to get help. Please let me know.

    Thank you!

    GP Premium 1.7.2
    #655451
    David
    Staff
    Customer Support

    Hi there,

    i think the error you have is unrelated to the problem.
    You may want to contact Elementor support but in the meantime they provide this help guide:

    https://docs.elementor.com/article/189-having-problems-using-elementor-start-here

    It is generally a low memory limit issue or can be caching.

    #655769
    Hannah

    Hi David,

    Thanks for getting back to me. I will contact Elementor but I think the issue is with GeneratePress because Elementor works fine as soon as I deactivate GeneratePress Premium…

    I have tried increasing the memory limit of my local host and purging my cache and neither have worked.

    Let me know if you have any other ideas.

    Thanks,
    Hannah

    #655792
    David
    Staff
    Customer Support

    Hi Hannah,

    can you check the PHP version. Make sure it is version 7.x and ideally you want at least 128meg if not higher memory.

    #655801
    Hannah

    Hi David,

    Yes, I am using PHP version 7.1.7 with 256M of memory. I tried raising this to 500M and it didn’t fix the issue.

    Thanks,
    Hannah

    #655804
    David
    Staff
    Customer Support

    OK, so make sure you have the latest GPP installed, then process of elimination. Can you deactivate all other plugins apart from Elementor/Pro and GP Premium?

    If the issue still persists can you deactivate each of the GP modules one by one and see if any of them are related.

    #655835
    Hannah

    Thanks David.

    Seems to be working now. The issue was caused by Hooks and Page Header being active when they’ve been deprecated.

    Thanks for your help!

    #655849
    David
    Staff
    Customer Support

    Well glad to hear you got it resolved. I will look into this 🙂

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.