[Resolved] element header question: default header when there is no other header

Home Forums Support [Resolved] element header question: default header when there is no other header

Home Forums Support element header question: default header when there is no other header

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #704829
    sg

    Hello, i understand there is header for entire site. there is also option to display default image when there is no feature image, but this overwrites for pages/post/cpt with another header present.

    is there any wordaround for this ?
    also notice there is a bug in the image upload. it doesnt show the uploaded images , need to save/refresh the page. i guess its not that big deal for now.

    thanks.

    GeneratePress 2.1.4
    GP Premium 1.7.2
    #704957
    David
    Staff
    Customer Support

    Hi there,

    Currently whichever Header Element was registered first gets priority over any subsequent headers that have the same display rules. Hence the need to use the Exclude rules to avoid conflicts.

    If you are requiring different Header Elements by Post Type then i would not use the Entire Site Rule. Instead just create one for each type. This reduces / removes the need of the Exclude rules and removes conflicts.

    I have not noticed the ‘bug’ relating to the image uploads. Maybe a cache or plugin conflict issue?

    #705441
    sg

    Hi David.

    Thanks for the update.
    i think the better way to approach this case is to publish all the related headers in sequence plus a warning at the element side , something like “other header exist” , whats your view on this ?

    2. the image upload bug, we can look into that later when i have time . cheers

    #705505
    Tom
    Lead Developer
    Lead Developer

    I looked into having multiple headers display, and it was chaos (code-wise and UX-wise). It was decided that using the oldest applied header was the better approach.

    As for the image upload issue – is that in the Media Library? It’s possible you have a plugin conflicting, or possibly a permissions error on your server. GeneratePress itself doesn’t interfere with the media library at all.

    #705525
    sg

    Hi tom,.

    Noted. thanks. what will happen if both old page header and the new element header activated same time for same conditions ?

    image upload issue is when updating the element with new images. ill look if there is any plugin conflict and update if there is anythigg found.

    #705561
    Tom
    Lead Developer
    Lead Developer

    They should both show up on top of each other.

    Sounds good – thanks!

    #705790
    sg

    closing this,. will re-open if any issue found,cheers

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.