[Resolved] Editing blog page

Home Forums Support Editing blog page

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #929942
    Daniel

    Hi,

    Just a query as I did a quick search and couldn’t see anything directly what I’m asking, sorry!

    1) How can I change the title on the top header of the blogs page? I simply want it to say ‘News’ instead of ‘blog’.

    2) How can I remove the footer widgets on the blogs page? I removed them on every other page as I don’t need them but I can’t see a way to take them off the blogs page.

    Again, apologies, I’m sure this is very simple but I’m new!

    Many thanks,
    Daniel

    #929971
    David
    Staff
    Customer Support

    Hi there,

    the site uses the Header Element:

    https://docs.generatepress.com/article/header-element-overview/

    So in Dashboard > Appearance > Elements – look for the Header Element assigned to the Blog. Edit the content to whatever you want eg.

    <h1>News</h1>

    If you’re not using footer widgets on any of the site then you can set them to zero in the Customizer > Layout > Footer.

    #930004
    Daniel

    Great, thank you. Fixed both of those things.

    I now have another query – hopefully that’s okay to post here instead of a new thread?

    I’m trying to add some space between the top of the white box in the image, using the content padding setting in the container > content padding setting.

    However, whatever I set the content padding number to, nothing actually affects the spacing, even though in the preview it looks like it does. The same issue occurs for both desktop and mobile.

    https://pasteboard.co/Ijr7mn2.jpg

    The second image shows the live preview (with the spacing as intended), but when I press publish, no space has actually been added. The value remains as set if I refresh the page, I can add more pixels and again it updates in the preview, but nothing actually changes when published.

    https://pasteboard.co/Ijr8A18.jpg

    Any ideas?

    #930014
    David
    Staff
    Customer Support

    Can you check the customizer settings to see if that top padding was saved? its currently showing only 3px

    #930193
    Daniel

    Hi,

    The settings are as per the image below. It says 30px as the top padding, but it’s definitely not.
    So it saves the padding number, but doesn’t actually affect the box.

    https://pasteboard.co/IjurRl0.jpg

    If I change the box to say, 60px, the live preview looks as if the spacing is now correct, however when I publish, nothing changes. If I then go back to the customizer, it will still say 60px but padding has not moved.

    Hope that makes some sort of sense.

    Daniel

    #930432
    David
    Staff
    Customer Support

    What if you change another customzier setting are those changes carried over to the front end? If nothing is changing then at the top of the Customizer click the Cog icon and make sure the Action isnt set to Save as Draft. Let me know

    #930593
    Daniel

    Nope, it’s definitely set to publish.

    Other changes seem to take affect, but nothing regarding content padding.
    Happy to provide you with a temporary login if you’d like to have a look yourself and make sure I’m not just being simple?

    Daniel

    #930641
    David
    Staff
    Customer Support

    One thing to check before we go for login – in Customizer > General > Cache Dyanamic CSS – is this option checked? If so can you uncheck it and flush any caches.

    If that don’t work then please send login via the Account issue from referencing the URL for this topic so we can track:

    https://generatepress.com/contact/

    #931841
    Daniel

    Hi, it was indeed checked so I turned it off and cleared my Siteground cache etc, unfortunately the problem still remains.

    I’ll send a temp login as discussed shortly.

    Many thanks,
    Daniel

    #931977
    David
    Staff
    Customer Support

    Aah didn’t spot it first time – the Align Wide option on a block offsets the padding with some negative margins so you need to add this CSS to stop that from happening:

    .entry-content > .alignwide:first-child, .entry-content > .alignfull:first-child {
        margin-top: 0;
    }
    #932336
    Daniel

    Perfect, that’s all fixed now.

    Thank you!

    #932469
    David
    Staff
    Customer Support

    Glad to be of help – we have accounted for this in the next theme update so when 2.3 arrives you won’t require that CSS

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.