[Support request] double featured images + left sidebar disappearing on posts

Home Forums Support double featured images + left sidebar disappearing on posts

This topic contains 8 replies, has 2 voices, and was last updated by  Leo 3 weeks, 6 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1007175

    cath

    Hi, I think I once asked this before – I did and went back to read it. Tom told me if I had a post set to full length and set featured image that it would show up twice. But also if I did not set a featured image, the image would appear when I shared it. At least this is how I read it… However, I just did a test and without featured image the image did not share to Facebook, it picked up the header.

    Also, but the first issue is more important right now, the left sidebar does not show when you click on a post. It only shows when you look at the site from the home page.

    Thank you!

    #1007191

    cath

    I somewhat worked around this by removing the top photo within the post so the featured image shows… not sure if that is best, but that’s what I did for now.

    I am wondering how I get the photo to appear under the headline of the blog post. Thanks!

    #1007202

    Leo Customer Support

    Hi there,

    Have you considered using a plugin like YoastSEO? Then you can actually set a picture you want to show when sharing on a platform like Facebook.

    As for the sidebar layout, can you check what your single post sidebar layout is in the customizer?
    https://docs.generatepress.com/article/sidebar-layout/

    Let me know 🙂

    #1007218

    cath

    Hi Leo,

    Thank you. I see what you mean about the two choices for the sidebar and that the blog has a separate choice. I had changed the main site to sidebar/content/sidebar but did not change the other. I think I will leave it as is for now, now that I think about it but good to know for the future. So that’s what that was.

    I’ve never really understood how Generate Press is set up with regards to featured images. You are saying there is no way to get around this… to set the Featured Image and yet not have two images on the post?

    I can look into Yoast SEO plugin but I do have another site with GP and I believe I added CSS – to ‘correct.’

    Other question: I’d like the top photo in the post to appear under the heading of the blog post, not above it on the post. How do I do that?

    Cath

    #1007229

    Leo Customer Support

    The featured image display settings shouldn’t be very complicated.

    You can set display/hide separately for Archives (posts page), Posts (single posts) and Pages (static pages):
    https://docs.generatepress.com/article/adjusting-the-featured-images/

    I’m not quite sure what the exact issue is but maybe you can set featured images to display in archives but hide them in single posts?

    Let me know if this helps 🙂

    #1013012

    cath

    Hi, no, this was not helpful, the link you sent me to.

    Can someone read what I wrote and help me here?

    1) Wanting not duplicate featured images on posts where they are full length. I think there is CSS that can be added?
    2) wanting to know how to have the photo underneath the title of the post, not above.

    Thanks.

    #1013023

    cath

    just a note, when I go to Customizer-> Layout-> Blog, those options do not come up. But nonetheless, I’m not sure if that would even answer my query.

    #1013024

    Leo Customer Support

    The link I provided above should do exactly that.

    1) Are you referring to single posts? If so then click Posts then uncheck display featured images:
    https://www.screencast.com/t/foJL1Db9r

    If you are referring to the posts listing page, then check Archives and do the same thing:
    https://www.screencast.com/t/3X55qV0Uf9

    2) Have you tried modifying the featured images location option?
    https://www.screencast.com/t/RiYhROq7

    #1013026

    Leo Customer Support

    Make sure to activate the Blog add-on:
    https://docs.generatepress.com/article/installing-gp-premium/#activate-your-modules

    And yes those options should do what you are hoping to achieve 🙂

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.