[Resolved] Custom font called but not loaded on Posts page Primary Nav

Home Forums Support Custom font called but not loaded on Posts page Primary Nav

This topic contains 17 replies, has 3 voices, and was last updated by  Tom 4 months ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #614616

    Alo

    Hey,

    Right now I’ve come full circle from another post on this forum, as I have ditched the Elementor navbar and am using GP-s own. Also, I uploaded my font as per your guidelines, and it loads for the Primary Nav on every page except “Blog/News”.

    Is there a rather simple fix or do I have to approach this in some other way?

    Cheers!

    GeneratePress 2.1.2
    GP Premium 1.6.2
    #614697

    David Customer Support

    Hi Alo,

    have you tried deleting the autoptimize cache?
    If it still persists can you leave autoptimize off and let us know.

    #614893

    Alo

    Hey David,

    Yeah turning off autoptimize and ansync JavaScript didn’t work. Will turn them back off in 5 minutes.

    Thanks!

    #615461

    David Customer Support

    Sorry we missed this topic. Just drop us an update here so me, Tom or Leo can have a look.

    #615463

    Alo

    Something like this? 🙂

    #615594

    David Customer Support

    Hi Alo,

    check your fontface CSS doesn’t look like you have the expressed the absolute path to them. Try adding the full URL to the src.

    Let me know

    #621388

    Alo

    Hei David, sorry for the long delay. I tried adding the full URL though (haven’t re-enabled Autoptimize yet either), and no game, still doesn’t load for the blog posts index page or single post pages.

    Any other ideas? :/

    #621626

    Tom Lead Developer

    Trying to find where you’ve defined @font-face but can’t. Your child theme CSS file is empty?

    Let me know 🙂

    #621668

    Alo

    Hey,

    Currently I have added it to the customizer CSS section. Should I add it to the child theme CSS file instead? I thought these two were essentially the same until now.

    Thanks for digging in though!

    #621839

    David Customer Support

    Hi Alo

    the standard rules are to add the fonts and the CSS to the child theme. Can you give that a shot?

    #622226

    Alo

    Hi David,

    Tried, added the css with full URL to the child theme’s style.css file via editor. No game :/

    #622228

    David Customer Support

    Where are you’re font files? Are they in the child theme fonts folder?

    #622230

    Alo

    Nope, the Uploads folder. Is that a big no no?

    EDIT: I also put the ttf file in the child theme fonts folder (didn’t have it originally) also and changed the URL in the css in the child theme style.css. Still not loading on the blog index and single post pages :/ Other page ok, as before though.

    #622289

    David Customer Support

    I can only see the font in the Uploads folder, no font folder in the child theme?
    If you can add them to the child theme / fonts folder and remove them from the attachments.

    #622299

    Alo

    Yeah, just did that, now it’s not displaying anywhere…

    EDIT: Okay, after adding the updated URL to Elementor Custom fonts as well, it is again showing on other pages/headings. Still nothing on the blog pages though.

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.